Difference between revisions of "Board:asrock/939a785gmh"

From coreboot
Jump to: navigation, search
(DualChannel worked after all)
m (Status)
(4 intermediate revisions by the same user not shown)
Line 24: Line 24:
  
 
Suspend LED is the power LED - register 0f3 in SIO. Low = on
 
Suspend LED is the power LED - register 0f3 in SIO. Low = on
 +
 +
=== PCIe x16 ===
 +
 +
Reset signal is through GPIO - GPM8,GPM9, 0 asserts reset, 1 de-asserts reset.
  
 
== Status ==
 
== Status ==
Line 43: Line 47:
 
|RAM_DDR3_status = N/A
 
|RAM_DDR3_status = N/A
 
|RAM_ecc_status = N/A
 
|RAM_ecc_status = N/A
 +
|RAM_dualchannel_status = OK
  
 
|IDE_status = OK
 
|IDE_status = OK
 
|IDE_comments = checked with a CD-ROM drive
 
|IDE_comments = checked with a CD-ROM drive
 
|IDE_25_status = N/A
 
|IDE_25_status = N/A
|SATA_status = WIP
+
|SATA_status = OK (check note)
 
|Onboard_SCSI_status = N/A
 
|Onboard_SCSI_status = N/A
 
|USB_status = OK
 
|USB_status = OK
Line 71: Line 76:
 
|PCIE_x4_status = N/A
 
|PCIE_x4_status = N/A
 
|PCIE_x8_status = N/A
 
|PCIE_x8_status = N/A
 +
|PCIE_x16_status = OK
 
|PCIE_x32_status = N/A
 
|PCIE_x32_status = N/A
 
|HTX_status = N/A
 
|HTX_status = N/A
Line 87: Line 93:
  
 
== Known Issues ==
 
== Known Issues ==
 +
 +
=== SATA ===
 +
 +
External and SATA port 4 is not detected. This is due to bug in Coreboot code with regards of Combined mode handling.
  
 
=== RAM ===
 
=== RAM ===
Line 112: Line 122:
  
 
=== PCI-E graphics adapter ===
 
=== PCI-E graphics adapter ===
* Wouldn't work. With both plugged in and CONFIG_CONSOLE_VGA_ONBOARD_AT_FIRST not set there was no video output. I had the vgabios for the onboard adapter still inside the coreboot.rom however.
+
* Should be now fixed - r6384
 +
 
  
 
=== Keyboard in Grub ===
 
=== Keyboard in Grub ===

Revision as of 19:58, 26 February 2011

Official site

Hardware details

Clock Chip

The clock chip is ICS 9LPRS485CGLF - Could be used for overclocking.

Sideport memory

It uses Elixir n2tu1g16dg-ac, DDR2 800 Mhz.

SuperIO

It uses Winbond W83627DHG. Its GPIOs are connected this way:

GP20 - sideport voltage 1 = 1.82V 0 = 1.92V

GPO40 | GPO41 | GPIO23 GPU voltage - 000 - 1.45V step 0.05 -- 111 - 1.10V

GPO35 - loadline control (0 enabled)

GPO44 | GPO45 | GPO46 - DDR memory voltage

Suspend LED is the power LED - register 0f3 in SIO. Low = on

PCIe x16

Reset signal is through GPIO - GPM8,GPM9, 0 asserts reset, 1 de-asserts reset.

Status

For the entries marked as WIP, please see below.

Device/functionality Status Comments
CPU
CPU works OK AMD Athlon(tm) 64 X2 Dual Core Processor 3800+
L1 cache enabled Unknown
L2 cache enabled Unknown
L3 cache enabled Unknown
Multiple CPU support N/A
Multi-core support OK AMD Athlon(tm) 64 X2 Dual Core Processor 3800+: htop and /proc/cpuinfo
Hardware virtualization Unknown
RAM
EDO N/A
SDRAM N/A
SO-DIMM N/A
DDR WIP
DDR2 N/A
DDR3 N/A
Dual channel support OK
ECC support N/A
On-board Hardware
On-board IDE 3.5" OK checked with a CD-ROM drive
On-board IDE 2.5" N/A
On-board SATA OK (check note)
On-board SCSI N/A
On-board USB OK only checked two ports so far, for mouse and keyboard.
On-board VGA WIP
On-board ethernet OK
On-board audio WIP Front works, Surround doesn't
On-board modem N/A
On-board FireWire N/A
On-board smartcard reader N/A
On-board CompactFlash N/A
On-board PCMCIA N/A
Add-on slots/cards
ISA add-on cards N/A
Audio/Modem-Riser (AMR/CNR) cards N/A
PCI add-on cards OK
Mini-PCI add-on cards N/A
PCI-X add-on cards N/A
AGP graphics cards N/A
PCI Express x1 add-on cards OK
PCI Express x2 add-on cards N/A
PCI Express x4 add-on cards N/A
PCI Express x8 add-on cards N/A
PCI Express x16 add-on cards OK
PCI Express x32 add-on cards N/A
HTX add-on cards N/A
Legacy / Super I/O
Floppy Unknown
Serial port 1 (COM1) Unknown
Serial port 2 (COM2) N/A
Parallel port Unknown
PS/2 keyboard Unknown
PS/2 mouse Unknown
Game port N/A
Infrared Unknown
PC speaker Unknown
DiskOnChip N/A
Miscellaneous
Sensors / fan control Unknown
Hardware watchdog Unknown
SMBus Unknown
CAN bus N/A
CPU frequency scaling Unknown
Other powersaving features Unknown
ACPI Unknown
Reboot OK
Poweroff OK
Suspend Unknown
Nonstandard LEDs N/A
High precision event timers (HPET) Unknown
Random number generator (RNG) N/A
Wake on modem ring Unknown
Wake on LAN Unknown
Wake on keyboard Unknown
Wake on mouse Unknown
Flashrom OK

Known Issues

SATA

External and SATA port 4 is not detected. This is due to bug in Coreboot code with regards of Combined mode handling.

RAM

Ruik tests

  • use 2x 512MB CAS 2.5 DDR400
  • blue slots populated = dualchannel mode (works)
  • all slots populated (with additional RAM) - strange UMA artefacts
  • only channel0 populated (DDR1 and DDR3 slot, DDR1 is closest to CPU) - strange UMA artefacts
  • single memory stick in DDR1 slot - works

Lennart tests

  • blue slots populated - works
  • all slots populated -- doesn't boot
    • hangs on "Clearing initial memory region:"
  • only channel0 populated - doesn't boot
    • hangs on "Clearing initial memory region:"
  • single DIMM in DDR1 - works.

Onboard VGA

  • In regard to the vendor BIOS the output numbers were switched. DVI-0 (vendor BIOS) was named HDMI-0 using coreboot.
  • Both VGA and DVI output worked.

PCI-E graphics adapter

  • Should be now fixed - r6384


Keyboard in Grub

  • The (USB) keyboard in Grub doesn't respond correctly. Every keypress triggers multiple actions.

Kernel

  • Linux 2.6.35.2 wouldn't boot. It would start, then the screens were going blank and the machine hung.