Difference between revisions of "Board:asrock/e350m1"

From coreboot
Jump to: navigation, search
(Status)
(tested yesterday, kvm works fine under libvirt of trisquel (guest was parabola).)
(10 intermediate revisions by 3 users not shown)
Line 13: Line 13:
 
|CPU_multicore_status = OK
 
|CPU_multicore_status = OK
 
|CPU_multicore_comments = Both cores seem to be detected.
 
|CPU_multicore_comments = Both cores seem to be detected.
|CPU_virt_status = Untested
+
|CPU_virt_status = OK
  
 
|RAM_EDO_status = N/A
 
|RAM_EDO_status = N/A
Line 35: Line 35:
 
|USB_comments =  
 
|USB_comments =  
 
|Onboard_VGA_status = OK
 
|Onboard_VGA_status = OK
|Onboard_VGA_comments = Must add VBIOS.
+
|Onboard_VGA_comments = You must add a VGA BIOS image. Use the nomodeset kernel command line option if you get garbled output immediately after starting the Linux kernel.
 
|Onboard_ethernet_status = WIP
 
|Onboard_ethernet_status = WIP
 
|Onboard_ethernet_comments = After reset the ethernet adapter might not be initialized properly, so OS won't be able to detect it. Unplugging power supply for a few seconds appears to get it back to life.
 
|Onboard_ethernet_comments = After reset the ethernet adapter might not be initialized properly, so OS won't be able to detect it. Unplugging power supply for a few seconds appears to get it back to life.
Line 51: Line 51:
 
|AGP_cards_status = N/A
 
|AGP_cards_status = N/A
 
|PCI_cards_status = N/A
 
|PCI_cards_status = N/A
|PCIE_x1_status = Untested
+
|PCIE_x1_status = OK
 +
|PCIE_x1_comments = Works at least with this ath9k wifi card(I only tested that card) : 01:00.0 Network controller [0280]: Qualcomm Atheros AR9485 Wireless Network Adapter [168c:0032] (rev 01)
 
|PCIE_x2_status = N/A
 
|PCIE_x2_status = N/A
 
|PCIE_x4_status = N/A
 
|PCIE_x4_status = N/A
Line 73: Line 74:
  
 
|Sensors_status = OK
 
|Sensors_status = OK
|Sensors_comments = CPU temperature seems to be displayed properly by lm-sensors.
+
|Sensors_comments = The CPU temperature seems to be displayed properly by lm-sensors.
 
|CAN_bus_status = N/A
 
|CAN_bus_status = N/A
|CPUfreq_status = WIP
+
|CPUfreq_status = OK
|CPUfreq_comments = the governor will switch the frequency to minimum(800 MHz) but it looks like it won't get increased back to higher values when under load
+
|CPUfreq_comments = The ondemand governor works by default.
|Powersave_status = WIP
+
|Powersave_status = OK
|Powersave_comments = The CPU fan rotates at maximum speed and won't answer to PWM commands
+
|Powersave_comments = By default the CPU fan rotates at maximum speed. See the fancontrol attachment below on how to get it adjust automatically depending on CPU temperature.
 
|ACPI_status = ?
 
|ACPI_status = ?
 
|ACPI_comments =  
 
|ACPI_comments =  
 
|Reboot_status = OK
 
|Reboot_status = OK
 
|Poweroff_status = OK
 
|Poweroff_status = OK
|Suspend_status = Untested
+
|Suspend_status = NO
 +
|Suspend_comments = The machine suspends but it fails to resume from suspend.
 
|LEDs_status = N/A
 
|LEDs_status = N/A
 
|HPET_status = Unknown
 
|HPET_status = Unknown
Line 96: Line 98:
  
 
Dumps of information gathered by various commands while running the proprietary BIOS are available here: [[File:ASRock_E350M1_info_dump.tar.bz2]]
 
Dumps of information gathered by various commands while running the proprietary BIOS are available here: [[File:ASRock_E350M1_info_dump.tar.bz2]]
 +
 +
Fancontrol configuration file for adjusting the CPU fan speed dynamically: [[File:Fancontrol.gz]]

Revision as of 05:47, 16 October 2013

Status

Device/functionality Status Comments
CPU
CPU works OK
L1 cache enabled OK
L2 cache enabled OK
L3 cache enabled N/A
Multiple CPU support N/A
Multi-core support OK Both cores seem to be detected.
Hardware virtualization OK
RAM
EDO N/A
SDRAM N/A
SO-DIMM N/A
DDR N/A
DDR2 N/A
DDR3 OK
Dual channel support N/A
ECC support N/A
On-board Hardware
On-board IDE 3.5" N/A
On-board IDE 2.5" N/A
On-board SATA OK
On-board SCSI N/A
On-board USB OK
On-board VGA OK You must add a VGA BIOS image. Use the nomodeset kernel command line option if you get garbled output immediately after starting the Linux kernel.
On-board ethernet WIP After reset the ethernet adapter might not be initialized properly, so OS won't be able to detect it. Unplugging power supply for a few seconds appears to get it back to life.
On-board audio OK
On-board modem N/A
On-board FireWire N/A
On-board smartcard reader N/A
On-board CompactFlash N/A
On-board PCMCIA N/A
Add-on slots/cards
ISA add-on cards N/A
Audio/Modem-Riser (AMR/CNR) cards N/A
PCI add-on cards N/A
Mini-PCI add-on cards N/A
PCI-X add-on cards N/A
AGP graphics cards N/A
PCI Express x1 add-on cards OK Works at least with this ath9k wifi card(I only tested that card) : 01:00.0 Network controller [0280]: Qualcomm Atheros AR9485 Wireless Network Adapter [168c:0032] (rev 01)
PCI Express x2 add-on cards N/A
PCI Express x4 add-on cards N/A
PCI Express x8 add-on cards N/A
PCI Express x16 add-on cards  ?
PCI Express x32 add-on cards N/A
HTX add-on cards N/A
Legacy / Super I/O
Floppy N/A
Serial port 1 (COM1) OK
Serial port 2 (COM2) N/A
Parallel port N/A
PS/2 keyboard Untested
PS/2 mouse Untested
Game port N/A
Infrared  ?
PC speaker  ?
DiskOnChip N/A
Miscellaneous
Sensors / fan control OK The CPU temperature seems to be displayed properly by lm-sensors.
Hardware watchdog Unknown
SMBus Unknown
CAN bus N/A
CPU frequency scaling OK The ondemand governor works by default.
Other powersaving features OK By default the CPU fan rotates at maximum speed. See the fancontrol attachment below on how to get it adjust automatically depending on CPU temperature.
ACPI  ?
Reboot OK
Poweroff OK
Suspend NO The machine suspends but it fails to resume from suspend.
Nonstandard LEDs N/A
High precision event timers (HPET) Unknown
Random number generator (RNG)  ?
Wake on modem ring Untested
Wake on LAN Untested
Wake on keyboard Untested
Wake on mouse Untested
Flashrom OK

Dumps of information gathered by various commands while running the proprietary BIOS are available here: File:ASRock E350M1 info dump.tar.bz2

Fancontrol configuration file for adjusting the CPU fan speed dynamically: File:Fancontrol.gz