Difference between revisions of "Board:asus/a8v-e deluxe"

From coreboot
Jump to: navigation, search
(Status update, most parts work fine now, booting from SATA works.)
Line 1: Line 1:
This page describes how to use coreboot on the '''ASUS A8V-E Deluxe''' mainboard. It is maintained by [[User:Uwe|Uwe Hermann]].
+
This page describes how to use coreboot on the '''[http://www.asus.com.tw/products.aspx?modelmenu=2&model=376&l1=3&l2=15&l3=143&l4=0 ASUS A8V-E Deluxe]''' mainboard. It is maintained by [[User:Uwe|Uwe Hermann]].
  
 
== Status ==
 
== Status ==
Line 7: Line 7:
 
|CPU_status = OK
 
|CPU_status = OK
 
|CPU_comments = I'm using: CPU model AMD Sempron(tm) Processor 3200+
 
|CPU_comments = I'm using: CPU model AMD Sempron(tm) Processor 3200+
|CPU_L1_status = Untested
+
|CPU_L1_status = OK
|CPU_L1_comments = TODO
+
|CPU_L1_comments = CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
|CPU_L2_status = Untested
+
|CPU_L2_status = OK
|CPU_L2_comments = TODO
+
|CPU_L2_comments = CPU: L2 Cache: 256K (64 bytes/line)
 
|CPU_L3_status = N/A
 
|CPU_L3_status = N/A
 
|CPU_multiple_status = N/A
 
|CPU_multiple_status = N/A
|CPU_multicore_status = N/A
+
|CPU_multicore_status = Untested
 
|CPU_multicore_comments = I don't have a multicore CPU to test with.
 
|CPU_multicore_comments = I don't have a multicore CPU to test with.
|CPU_virt_status = N/A
+
|CPU_virt_status = Untested
  
 
|RAM_EDO_status = N/A
 
|RAM_EDO_status = N/A
Line 24: Line 24:
 
|RAM_DDR2_comments = TODO
 
|RAM_DDR2_comments = TODO
 
|RAM_DDR3_status = N/A
 
|RAM_DDR3_status = N/A
|RAM_dualchannel_status =  
+
|RAM_dualchannel_status = Untested
|RAM_ecc_status =  
+
|RAM_ecc_status = Untested
  
 
|IDE_status =  
 
|IDE_status =  
Line 31: Line 31:
 
|IDE_25_status = N/A
 
|IDE_25_status = N/A
 
|CDROM_DVD_status = Untested
 
|CDROM_DVD_status = Untested
|SATA_status =  
+
|SATA_status = OK
|SATA_comments =  
+
|SATA_comments = Tested: SATA port 1 (hda in [[FILO]]).
|USB_status =  
+
|USB_status = OK
|USB_comments =  
+
|USB_comments = Tested: USB keyboard on all 4 USB ports.
 
|Onboard_VGA_status = N/A
 
|Onboard_VGA_status = N/A
|Onboard_ethernet_status =  
+
|Onboard_ethernet_status = OK
|Onboard_audio_status =  
+
|Onboard_audio_status = OK
 
|Onboard_modem_status =  
 
|Onboard_modem_status =  
|Onboard_firewire_status =  
+
|Onboard_firewire_status = Untested
 
|Smartcard_status = N/A
 
|Smartcard_status = N/A
 
|Onboard_CF_status = N/A
 
|Onboard_CF_status = N/A
Line 47: Line 47:
 
|AMR_cards_status = N/A
 
|AMR_cards_status = N/A
 
|AGP_cards_status = N/A
 
|AGP_cards_status = N/A
|PCI_cards_status =  
+
|PCI_cards_status = OK
|PCI_cards_comments =  
+
|PCI_cards_comments = Tested: PCI VGA card in slot 3.
|PCIE_x1_status =  
+
|PCIE_x1_status = Untested
|PCIE_x2_status =  
+
|PCIE_x2_status = N/A
|PCIE_x4_status =  
+
|PCIE_x4_status = N/A
|PCIE_x8_status =  
+
|PCIE_x8_status = N/A
|PCIE_x16_status =  
+
|PCIE_x16_status = Untested
|PCIE_x32_status =  
+
|PCIE_x32_status = N/A
 
|HTX_status = N/A
 
|HTX_status = N/A
  
|Floppy_status =  
+
|Floppy_status = Untested
 
|COM1_status = OK
 
|COM1_status = OK
 
|COM2_status = N/A
 
|COM2_status = N/A
|PP_status =  
+
|PP_status = OK
|PS2_keyboard_status =  
+
|PP_comments = Doing '''modprobe ppdev''' works fine, but further tests were not performed.
|PS2_mouse_status =  
+
|PS2_keyboard_status = OK
|Game_port_status =  
+
|PS2_mouse_status = OK
 +
|Game_port_status = Untested
 
|IR_status =  
 
|IR_status =  
|Speaker_status =  
+
|Speaker_status = OK
 
|DiskOnChip_status = N/A
 
|DiskOnChip_status = N/A
  
|Sensors_status =  
+
|Sensors_status = OK
 +
|Sensors_comments = The '''k8temp''' module loads fine, the '''sensors''' tool outputs the CPU temperature (of both cores in my case) correctly. The '''w83627ehf''' module (for various temperatures and fan speeds) works fine. Also, the '''eeprom''' and '''i2c-nforce2''' modules load fine.
 
|Watchdog_status =  
 
|Watchdog_status =  
 
|CAN_bus_status = N/A
 
|CAN_bus_status = N/A
Line 77: Line 79:
 
|Poweroff_status =  
 
|Poweroff_status =  
 
|LEDs_status =  
 
|LEDs_status =  
|HPET_status =  
+
|HPET_status = OK
 +
|HPET_comments = The '''dmesg''' output has '''ACPI: HPET id: 0x102282a0 base: 0xfed00000''', and '''hpet0: at MMIO 0xfed00000, IRQs 2, 8, 0''', and '''hpet0: 3 32-bit timers, 14318180 Hz''', but no further tests were performed so far.
 
|RNG_status =  
 
|RNG_status =  
 
|WakeOnModem_status = Untested
 
|WakeOnModem_status = Untested
Line 159: Line 162:
 
The resulting '''coreboot.rom''' (512 KB) can now be flashed on a ROM chip.
 
The resulting '''coreboot.rom''' (512 KB) can now be flashed on a ROM chip.
  
So far it boots up to a FILO prompt for me, but there is an issue with IDE drive detection, it seems. I'll fix this, and also test SATA drives, those might already work fine.
+
So far it boots up to a FILO prompt for me, but there is an issue with IDE drive detection, it seems. I'll investigate.
 +
Booting from SATA (port 1 tested so far) works fine.
  
  
 
{{GPL}}
 
{{GPL}}

Revision as of 21:21, 5 March 2008

This page describes how to use coreboot on the ASUS A8V-E Deluxe mainboard. It is maintained by Uwe Hermann.

Status

Device/functionality Status Comments
CPU
CPU works OK I'm using: CPU model AMD Sempron(tm) Processor 3200+
L1 cache enabled OK CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
L2 cache enabled OK CPU: L2 Cache: 256K (64 bytes/line)
L3 cache enabled N/A
Multiple CPU support N/A
Multi-core support Untested I don't have a multicore CPU to test with.
Hardware virtualization Untested
RAM
EDO N/A
SDRAM N/A
SO-DIMM N/A
DDR N/A
DDR2 OK TODO
DDR3 N/A
Dual channel support Untested
ECC support Untested
On-board Hardware
On-board IDE 3.5"
On-board IDE 2.5" N/A
On-board SATA OK Tested: SATA port 1 (hda in FILO).
On-board SCSI Unknown
On-board USB OK Tested: USB keyboard on all 4 USB ports.
On-board VGA N/A
On-board ethernet OK
On-board audio OK
On-board modem
On-board FireWire Untested
On-board smartcard reader N/A
On-board CompactFlash N/A
On-board PCMCIA N/A
Add-on slots/cards
ISA add-on cards N/A
Audio/Modem-Riser (AMR/CNR) cards N/A
PCI add-on cards OK Tested: PCI VGA card in slot 3.
Mini-PCI add-on cards Unknown
PCI-X add-on cards Unknown
AGP graphics cards N/A
PCI Express x1 add-on cards Untested
PCI Express x2 add-on cards N/A
PCI Express x4 add-on cards N/A
PCI Express x8 add-on cards N/A
PCI Express x16 add-on cards Untested
PCI Express x32 add-on cards N/A
HTX add-on cards N/A
Legacy / Super I/O
Floppy Untested
Serial port 1 (COM1) OK
Serial port 2 (COM2) N/A
Parallel port OK Doing modprobe ppdev works fine, but further tests were not performed.
PS/2 keyboard OK
PS/2 mouse OK
Game port Untested
Infrared
PC speaker OK
DiskOnChip N/A
Miscellaneous
Sensors / fan control OK The k8temp module loads fine, the sensors tool outputs the CPU temperature (of both cores in my case) correctly. The w83627ehf module (for various temperatures and fan speeds) works fine. Also, the eeprom and i2c-nforce2 modules load fine.
Hardware watchdog
SMBus Unknown
CAN bus N/A
CPU frequency scaling
Other powersaving features
ACPI
Reboot
Poweroff
Suspend Unknown
Nonstandard LEDs
High precision event timers (HPET) OK The dmesg output has ACPI: HPET id: 0x102282a0 base: 0xfed00000, and hpet0: at MMIO 0xfed00000, IRQs 2, 8, 0, and hpet0: 3 32-bit timers, 14318180 Hz, but no further tests were performed so far.
Random number generator (RNG)
Wake on modem ring Untested
Wake on LAN Untested
Wake on keyboard Untested
Wake on mouse Untested
Flashrom OK Works fine with the proprietary BIOS, untested in coreboot.

Hardware

  • AMD K8
  • VIA K8T890
  • VIA VT8237R
  • Winbond W83627EHF

Detailed System Information

lspci -tvnn

-[0000:00]-+-00.0  VIA Technologies, Inc. K8T890 Host Bridge [1106:0238]
           +-00.1  VIA Technologies, Inc. K8T890 Host Bridge [1106:1238]
           +-00.2  VIA Technologies, Inc. K8T890 Host Bridge [1106:2238]
           +-00.3  VIA Technologies, Inc. K8T890 Host Bridge [1106:3238]
           +-00.4  VIA Technologies, Inc. K8T890 Host Bridge [1106:4238]
           +-00.5  VIA Technologies, Inc. K8T890 I/O APIC Interrupt Controller [1106:5238]
           +-00.7  VIA Technologies, Inc. K8T890 Host Bridge [1106:7238]
           +-01.0-[0000:01]--
           +-02.0-[0000:02]--
           +-03.0-[0000:03]--
           +-03.1-[0000:04]--
           +-03.2-[0000:05]----00.0  Marvell Technology Group Ltd. 88E8053 PCI-E Gigabit Ethernet Controller [11ab:4362]
           +-03.3-[0000:06]--
           +-07.0  Marvell Technology Group Ltd. 88W8310 and 88W8000G [Libertas] 802.11g client chipset [11ab:1fa7]
           +-08.0  Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link) [104c:8023]
           +-0b.0  ATI Technologies Inc 3D Rage Pro 215GP [1002:4750]
           +-0f.0  VIA Technologies, Inc. VIA VT6420 SATA RAID Controller [1106:3149]
           +-0f.1  VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE [1106:0571]
           +-10.0  VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller [1106:3038]
           +-10.1  VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller [1106:3038]
           +-10.2  VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller [1106:3038]
           +-10.3  VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller [1106:3038]
           +-10.4  VIA Technologies, Inc. USB 2.0 [1106:3104]
           +-11.0  VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South] [1106:3227]
           +-11.5  VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller [1106:3059]
           +-11.6  VIA Technologies, Inc. AC'97 Modem Controller [1106:3068]
           +-18.0  Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration [1022:1100]
           +-18.1  Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map [1022:1101]
           +-18.2  Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller [1022:1102]
           \-18.3  Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control [1022:1103]

Building coreboot

Currently there is no special target for the ASUS A8V-E Deluxe in coreboot. Instead, we use the ASUS A8V-E SE target.

You have to apply the following patch to svn so the board boots (at least when using a Sempron CPU which doesn't seem to support an LDT frequency of 1000MHz):

Index: src/mainboard/asus/a8v-e_se/cache_as_ram_auto.c
===================================================================
--- src/mainboard/asus/a8v-e_se/cache_as_ram_auto.c     (revision 3127)
+++ src/mainboard/asus/a8v-e_se/cache_as_ram_auto.c     (working copy)
@@ -308,7 +308,7 @@
        needs_reset |= optimize_link_incoherent_ht(sysinfo);

        /* Fixme it assumes that 1000MHz LDT is selected. */
-       needs_reset |= k8t890_early_setup_car(16, 0x6);
+       needs_reset |= k8t890_early_setup_car(16, 0x5);

        if (needs_reset) {
                print_debug("ht reset -\r\n");

Then, place your payload (usually FILO) into /tmp/filo.elf and build coreboot as usual:

$ cd target
$ ./buildtarget asus/a8v-e_se && cd asus/a8v-e_se/asus_a8v-e_se && make

The resulting coreboot.rom (512 KB) can now be flashed on a ROM chip.

So far it boots up to a FILO prompt for me, but there is an issue with IDE drive detection, it seems. I'll investigate. Booting from SATA (port 1 tested so far) works fine.


GNU head This work is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or any later version. This work is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.