Difference between revisions of "Board:asus/a8v-e se"

From coreboot
Jump to: navigation, search
(Add motherboard hardware section)
(8 intermediate revisions by one other user not shown)
Line 5: Line 5:
 
|CPU_status = OK
 
|CPU_status = OK
 
|CPU_comments = I'm using an AMD Opteron 175 Dual Core Processor, both cores do work, Opteron 144 worked too.
 
|CPU_comments = I'm using an AMD Opteron 175 Dual Core Processor, both cores do work, Opteron 144 worked too.
 +
|CPU_L1_status = OK
 +
|CPU_L1_comments =
 +
|CPU_L2_status = OK
 +
|CPU_L2_comments =
 +
|CPU_L3_status = N/A
 +
|CPU_multiple_status = N/A
 +
|CPU_multicore_status = OK
 +
|CPU_multicore_comments = Opteron 175
 +
|CPU_virt_status = Untested
 +
  
 
|RAM_EDO_status = N/A
 
|RAM_EDO_status = N/A
Line 15: Line 25:
  
 
|IDE_status = OK
 
|IDE_status = OK
 +
|IDE_comments = '''USE 80 WIRE CABLES OR ALTER CONFIGURATION!'''
 
|IDE_25_status = N/A
 
|IDE_25_status = N/A
 
|IDE_CF_status = Untested
 
|IDE_CF_status = Untested
Line 73: Line 84:
 
= Motherboard GPIO configuration =
 
= Motherboard GPIO configuration =
  
It seems only GPIO2 and GPIO5 is used from W83627EHF/EHG.
+
It seems only GPIO2 and GPIO5 is used from W83627EHF/EHG. VT8237GPIO is perhaps used for CABLE select
 +
and with GP0 one can blink the power LED.
  
 
== GPIO2 (0xE4) ==
 
== GPIO2 (0xE4) ==
Line 98: Line 110:
  
 
=== GPIO2 bit 2 ===
 
=== GPIO2 bit 2 ===
output always 1 ???
+
output always 1 ??? maybe it is connected as turbo# on clock chip.
  
 
=== GPIO2 bit 1 ===
 
=== GPIO2 bit 1 ===
input
+
unused input (set to MOSI/MISO in CR29)
  
 
=== GPIO2 bit 0 ===
 
=== GPIO2 bit 0 ===
input
+
unused input (set to MOSI/MISO in CR29)
 
+
  
 
== GPIO5 (0xE1) ==
 
== GPIO5 (0xE1) ==
  
bit5 and bit0 are outputs, rest is input. no inversions.
+
bit5 and bit0 are outputs, rest is not used as GPIO. No inversions.
 +
CR2D is 0x21 it means only GP50 and GP55 are used for GPIO.
  
 
=== GPIO5 bit5 ===
 
=== GPIO5 bit5 ===
Line 116: Line 128:
 
=== GPIO5 bit0 ===
 
=== GPIO5 bit0 ===
 
memory voltage select
 
memory voltage select
 +
  
 
{|
 
{|

Revision as of 14:04, 16 November 2008

Status

Device/functionality Status Comments
CPU
CPU works OK I'm using an AMD Opteron 175 Dual Core Processor, both cores do work, Opteron 144 worked too.
L1 cache enabled OK
L2 cache enabled OK
L3 cache enabled N/A
Multiple CPU support N/A
Multi-core support OK Opteron 175
Hardware virtualization Untested
RAM
EDO N/A
SDRAM N/A
SO-DIMM N/A
DDR OK Works with patches I posted to the list.
DDR2 Unknown
DDR3 Unknown
Dual channel support OK According to memtest86+ it works.
ECC support Unknown
On-board Hardware
On-board IDE 3.5" OK USE 80 WIRE CABLES OR ALTER CONFIGURATION!
On-board IDE 2.5" N/A
On-board SATA OK
On-board SCSI Unknown
On-board USB OK Tested: USB thumb drive.
On-board VGA N/A
On-board ethernet OK
On-board audio OK
On-board modem N/A
On-board FireWire Unknown
On-board smartcard reader N/A
On-board CompactFlash Unknown
On-board PCMCIA Unknown
Add-on slots/cards
ISA add-on cards N/A
Audio/Modem-Riser (AMR/CNR) cards Unknown
PCI add-on cards OK
Mini-PCI add-on cards Unknown
PCI-X add-on cards Unknown
AGP graphics cards N/A
PCI Express x1 add-on cards OK
PCI Express x2 add-on cards N/A
PCI Express x4 add-on cards N/A
PCI Express x8 add-on cards N/A
PCI Express x16 add-on cards OK Graphics card works.
PCI Express x32 add-on cards N/A
HTX add-on cards N/A
Legacy / Super I/O
Floppy Untested
Serial port 1 (COM1) OK
Serial port 2 (COM2) N/A
Parallel port Untested Doing modprobe parport parport_pc works, but no further tests were done.
PS/2 keyboard OK
PS/2 mouse OK
Game port Unknown
Infrared Unknown
PC speaker Unknown
DiskOnChip N/A
Miscellaneous
Sensors / fan control OK
Hardware watchdog Unknown
SMBus Unknown
CAN bus N/A
CPU frequency scaling OK All you need is to patch the DSDT table with your CPU performance state settings.
Other powersaving features Unknown
ACPI OK ACPI power button event works.
Reboot OK
Poweroff OK
Suspend Unknown
Nonstandard LEDs Unknown TODO: Are there special-purpose LEDs on this board?
High precision event timers (HPET) OK
Random number generator (RNG) Unknown
Wake on modem ring Unknown
Wake on LAN Unknown
Wake on keyboard Unknown
Wake on mouse Unknown
Flashrom OK

Motherboard hardware list

  • AMD K8
  • VIA K8T890
  • VIA VT8237
  • W83627EHF
  • ICS ICS953202
  • Semtech SC2643VX

Motherboard GPIO configuration

It seems only GPIO2 and GPIO5 is used from W83627EHF/EHG. VT8237GPIO is perhaps used for CABLE select and with GP0 one can blink the power LED.

GPIO2 (0xE4)

No inversions, bit0 and bit1 inputs, rest configured as outputs.

GPIO2 bit7

memory voltage select

GPIO2 bit 6

memory voltage select

GPIO2 bit 5

1 = vcore offset + 100mV 0 = vcore offset + 200mV

GPIO2 bit 4

1 = 1.5V Chipset voltage 0 = 1.6V Chipset voltage

GPIO2 bit 3

0 = VID can be changed 1 = LockVID

GPIO2 bit 2

output always 1 ??? maybe it is connected as turbo# on clock chip.

GPIO2 bit 1

unused input (set to MOSI/MISO in CR29)

GPIO2 bit 0

unused input (set to MOSI/MISO in CR29)

GPIO5 (0xE1)

bit5 and bit0 are outputs, rest is not used as GPIO. No inversions. CR2D is 0x21 it means only GP50 and GP55 are used for GPIO.

GPIO5 bit5

memory voltage select

GPIO5 bit0

memory voltage select


Memory voltage adjustment
Voltage GPIO5 bit 5/0 GPIO2 bit 7/6
2.60V 11 01
2.65V 01 11
2.70V 00 11
2.75V 01 10
2.80V 10 00
2.85V 00 10
2.90V 00 01
2.95V 01 00
3.00V 00?? 00??