Difference between revisions of "Board:hp/dl145 g3"

From coreboot
Jump to: navigation, search
(Status: Reference template instead of copying it)
m (Issues)
(14 intermediate revisions by 2 users not shown)
Line 1: Line 1:
This page describes how to use coreboot on the HP DL145 G3 1U server. It is maintained by [[User:ElAngelo|ElAngelo]].
+
This page describes how to use coreboot on the '''HP DL145 G3''' 1U server. It is maintained by [[User:ElAngelo|ElAngelo]].
  
The manual of the machine is available at [http://bizsupport1.austin.hp.com/bc/docs/support/SupportManual/c00856243/c00856243.pdf hp.com]
+
The manual of the machine is available at [http://bizsupport1.austin.hp.com/bc/docs/support/SupportManual/c00856243/c00856243.pdf hp.com].
  
The main reason for the port is that the bios from HP does not support hardware virtualization on the cpu's.
+
The main reason for the port is that the BIOS from HP does not support hardware virtualization on the CPUs.
  
Following status was achieved with patches. Current svn revision (4080) does '''NOT''' support this machine.
+
== Status ==
[http://www.coreboot.org/pipermail/coreboot/2009-March/046076.html Thread on mailing list] with initial support for this mainboard
+
 
+
==Status==
+
  
 
{{Status|
 
{{Status|
Line 18: Line 15:
 
|CPU_L3_status = Unknown
 
|CPU_L3_status = Unknown
 
|CPU_multiple_status = OK
 
|CPU_multiple_status = OK
|CPU_multiple_comments = both cpu's work just fine
+
|CPU_multiple_comments = Both CPUs work just fine.
 
|CPU_multicore_status = OK
 
|CPU_multicore_status = OK
|CPU_multicore_comments = all cores of the cpu's show up in /proc/cpuinfo
+
|CPU_multicore_comments = All cores of the CPUs show up in '''/proc/cpuinfo'''.
 
|CPU_virt_status = OK
 
|CPU_virt_status = OK
|CPU_virt_comments = Hardware virtualization with [http://www.linux-kvm.org kvm on linux] was tested
+
|CPU_virt_comments = Hardware virtualization with [http://www.linux-kvm.org kvm on Linux] was tested.
  
 
|RAM_EDO_status = N/A
 
|RAM_EDO_status = N/A
Line 29: Line 26:
 
|RAM_DDR_status = N/A
 
|RAM_DDR_status = N/A
 
|RAM_DDR2_status = OK
 
|RAM_DDR2_status = OK
 +
|RAM_DDR2_comments = Tested with 4* 2GB Kingston Reg ECC DDR6400 (Kingston KVR667D2D8P5/2G)
 
|RAM_DDR3_status = N/A
 
|RAM_DDR3_status = N/A
|RAM_dualchannel_status = Unknown
+
|RAM_dualchannel_status = OK
|RAM_ecc_status = Unknown
+
|RAM_ecc_status = OK
  
 
|IDE_status = Unknown
 
|IDE_status = Unknown
 
|IDE_25_status = N/A
 
|IDE_25_status = N/A
 
|SATA_status = OK
 
|SATA_status = OK
|SATA_comments = needs patch
+
|SATA_comments = Needs time-out in [[FILO]].
 
|Onboard_SCSI_status = N/A
 
|Onboard_SCSI_status = N/A
 
|USB_status = Unknown
 
|USB_status = Unknown
|Onboard_VGA_status = FAIL
+
|Onboard_VGA_status = OK
 +
|Onboard_VGA_comments = VGA ROM at http://157.193.85.173/~samuel/matrox.rom could only be loaded with [[SeaBIOS]].
 
|Onboard_ethernet_status = OK
 
|Onboard_ethernet_status = OK
 
|Onboard_ethernet_comments = Untested: eth1
 
|Onboard_ethernet_comments = Untested: eth1
Line 62: Line 61:
 
|PCIE_x32_status = N/A
 
|PCIE_x32_status = N/A
 
|HTX_status = OK
 
|HTX_status = OK
|HTX_comments = 09:25-ijuz_-HTX card was tested, is OK (irc)
+
|HTX_comments = ''09:25-ijuz_: HTX card was tested, is OK'' (IRC)
  
 
|Floppy_status = N/A
 
|Floppy_status = N/A
Line 77: Line 76:
 
|Sensors_status = Unknown
 
|Sensors_status = Unknown
 
|Watchdog_status = Unknown
 
|Watchdog_status = Unknown
|SMBus_status = Unknown
+
|SMBus_status = N/A
|CAN_bus_status = Unknown
+
|CAN_bus_status = N/A
 
|CPUfreq_status = Unknown
 
|CPUfreq_status = Unknown
 
|Powersave_status = Unknown
 
|Powersave_status = Unknown
|ACPI_status = NO
+
|ACPI_status = No
 
|Reboot_status = OK
 
|Reboot_status = OK
|Poweroff_status = NO
+
|Poweroff_status = No
 
|LEDs_status = Unknown
 
|LEDs_status = Unknown
 
|HPET_status = Unknown
 
|HPET_status = Unknown
Line 91: Line 90:
 
|WakeOnKeyboard_status = Unknown
 
|WakeOnKeyboard_status = Unknown
 
|WakeOnMouse_status = Unknown
 
|WakeOnMouse_status = Unknown
|Flashrom_status = Unknown
+
|Flashrom_status = OK
  
 
}}
 
}}
 +
 +
== Issues ==
 +
 +
* Noticed that the port has a timer problem (time is moving at double speed). This is being investigated.
 +
* temporary workaround: add ''clocksource=tsc'' to the cmdline of the bootloader

Revision as of 14:10, 17 August 2009

This page describes how to use coreboot on the HP DL145 G3 1U server. It is maintained by ElAngelo.

The manual of the machine is available at hp.com.

The main reason for the port is that the BIOS from HP does not support hardware virtualization on the CPUs.

Status

Device/functionality Status Comments
CPU
CPU works OK 2 AMD Opteron 2218HE
L1 cache enabled Unknown
L2 cache enabled Unknown
L3 cache enabled Unknown
Multiple CPU support OK Both CPUs work just fine.
Multi-core support OK All cores of the CPUs show up in /proc/cpuinfo.
Hardware virtualization OK Hardware virtualization with kvm on Linux was tested.
RAM
EDO N/A
SDRAM N/A
SO-DIMM N/A
DDR N/A
DDR2 OK Tested with 4* 2GB Kingston Reg ECC DDR6400 (Kingston KVR667D2D8P5/2G)
DDR3 N/A
Dual channel support OK
ECC support OK
On-board Hardware
On-board IDE 3.5" Unknown
On-board IDE 2.5" N/A
On-board SATA OK Needs time-out in FILO.
On-board SCSI N/A
On-board USB Unknown
On-board VGA OK VGA ROM at http://157.193.85.173/~samuel/matrox.rom could only be loaded with SeaBIOS.
On-board ethernet OK Untested: eth1
On-board audio N/A
On-board modem N/A
On-board FireWire N/A
On-board smartcard reader N/A
On-board CompactFlash N/A
On-board PCMCIA N/A
Add-on slots/cards
ISA add-on cards N/A
Audio/Modem-Riser (AMR/CNR) cards N/A
PCI add-on cards N/A
Mini-PCI add-on cards N/A
PCI-X add-on cards Unknown
AGP graphics cards N/A
PCI Express x1 add-on cards N/A
PCI Express x2 add-on cards N/A
PCI Express x4 add-on cards Unknown
PCI Express x8 add-on cards Unknown
PCI Express x16 add-on cards Unknown
PCI Express x32 add-on cards N/A
HTX add-on cards OK 09:25-ijuz_: HTX card was tested, is OK (IRC)
Legacy / Super I/O
Floppy N/A
Serial port 1 (COM1) OK
Serial port 2 (COM2) N/A
Parallel port N/A
PS/2 keyboard OK
PS/2 mouse N/A
Game port N/A
Infrared N/A
PC speaker N/A
DiskOnChip N/A
Miscellaneous
Sensors / fan control Unknown
Hardware watchdog Unknown
SMBus N/A
CAN bus N/A
CPU frequency scaling Unknown
Other powersaving features Unknown
ACPI No
Reboot OK
Poweroff No
Suspend Unknown
Nonstandard LEDs Unknown
High precision event timers (HPET) Unknown
Random number generator (RNG) Unknown
Wake on modem ring Unknown
Wake on LAN Unknown
Wake on keyboard Unknown
Wake on mouse Unknown
Flashrom OK

Issues

  • Noticed that the port has a timer problem (time is moving at double speed). This is being investigated.
* temporary workaround: add clocksource=tsc to the cmdline of the bootloader