Board:msi/ms7260

From coreboot
Revision as of 17:18, 7 November 2007 by Uwe (Talk | contribs)

Jump to: navigation, search
The MSI MS-7260 (K9N Neo), revision 1.0

This page describes how to use LinuxBIOS on the MSI MS-7260 (K9N Neo) mainboard. It is maintained by Uwe Hermann.

The mainboard

Some more information on the board is available in the mailing list archives.

So far we have verified that revision 1.0 of the mainboard has a socketed PLCC32 ROM chip (512KB).

If you have any other revision of the board, please contact us on the mailing list and let us know if it has a socketed (and PLCC-type) ROM chip.


Status

Device/functionality Status Comments
CPU
CPU works OK I'm using an AMD Athlon 64 X2 Dual Core Processor 3600+, both cores work fine.
L1 cache enabled Unknown
L2 cache enabled Unknown
L3 cache enabled Unknown
Multiple CPU support Unknown
Multi-core support Unknown
Hardware virtualization Unknown
RAM
EDO N/A
SDRAM N/A
SO-DIMM N/A
DDR N/A
DDR2 OK It seems some combinations of DIMMs and RAM slots don't work. Using only one DIMM (in slot 1) works for me.
DDR3 Unknown
Dual channel support Unknown
ECC support Unknown
On-board Hardware
On-board IDE 3.5" OK
On-board IDE 2.5" N/A
On-board SATA OK Tested with a 40 GB SATA disk, connected to the "SATA1" connector of the board (there are four). Works with hde2:/vmlinuz initrd=/initrd.img root=/dev/sda2 in FILO (my Linux partition is /dev/sda2). Mounting the drive also works fine when you don't boot from SATA (e.g. from IDE or via etherboot).
On-board SCSI Unknown
On-board USB OK Tested: USB thumb drive, USB keyboard, USB webcam, USB DVB-T adapter.
On-board VGA N/A
On-board ethernet OK
On-board audio OK
On-board modem Unknown
On-board FireWire Unknown
On-board smartcard reader N/A
On-board CompactFlash N/A
On-board PCMCIA N/A
Add-on slots/cards
ISA add-on cards N/A
Audio/Modem-Riser (AMR/CNR) cards Unknown
PCI add-on cards OK There were some problems with PCI add-on cards, but they're fixed as of svn revision 2807. Tested using a PCI VGA add-on card, X11 works fine.
Mini-PCI add-on cards Unknown
PCI-X add-on cards Unknown
AGP graphics cards N/A
PCI Express x1 add-on cards Untested
PCI Express x2 add-on cards N/A
PCI Express x4 add-on cards N/A
PCI Express x8 add-on cards N/A
PCI Express x16 add-on cards Untested
PCI Express x32 add-on cards N/A
HTX add-on cards N/A
Legacy / Super I/O
Floppy Untested
Serial port 1 (COM1) OK
Serial port 2 (COM2) N/A
Parallel port Untested
PS/2 keyboard Untested
PS/2 mouse Untested
Game port Unknown
Infrared Unknown
PC speaker Unknown
DiskOnChip N/A
Miscellaneous
Sensors / fan control OK The k8temp module loads fine, the sensors tool outputs the CPU temperature (both cores in my case) correctly.
Hardware watchdog Unknown
SMBus Unknown
CAN bus N/A
CPU frequency scaling OK Probably won't work as long as there's no ACPI implementation for this board(?)
Other powersaving features Unknown
ACPI No
Reboot Unknown
Poweroff Unknown
Suspend Unknown
Nonstandard LEDs Unknown
High precision event timers (HPET) Unknown
Random number generator (RNG) Unknown
Wake on modem ring Unknown
Wake on LAN Unknown
Wake on keyboard Unknown
Wake on mouse Unknown
Flashrom OK Currently Flashrom works fine with LinuxBIOS, but it does not yet work with the proprietary BIOS.

Building LinuxBIOS

Build a LinuxBIOS payload, e.g. FILO, and copy the resulting file to /tmp/filo.elf.

$ cp payload.file /tmp/filo.elf

Checkout LinuxBIOS:

$ svn co svn://linuxbios.org/repos/trunk/LinuxBIOSv2

Build the LinuxBIOS image, containing the payload.

$ cd LinuxBIOSv2/targets
$ ./buildtarget msi/ms7260
$ cd msi/ms7260/ms7260
$ make

Write the LinuxBIOS image onto your ROM chip using flashrom:

$ flashrom -wv linuxbios.rom
WARNING: This will overwrite your current BIOS! Make sure you know what you're doing! You should have a way to revert back to the original BIOS in case anything goes wrong. It's a good idea to have a spare ROM chip which contains the original proprietary BIOS. Read the FAQ for more information. If in doubt, contact the mailing list.

Note: At the moment flashrom does not work in the MS-7260 (when booted using the original BIOS). Thus, I'm flashing the ROM chip in a different mainboard where flashrom works. However, flashrom works just fine once the MS-7260 is booted using LinuxBIOS.

TODO

  • Test the devices marked as "Untested" in the above status table.
  • Fix flashrom to also work when the board is booted using the proprietary BIOS.


GNU head This work is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or any later version. This work is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.