smartcore PIII is up; G2 & G4 efforts started.

Phil Brooks PhilB at
Wed Oct 30 20:54:00 CET 2002


Is this the Advanced Digital Logic MSMP3-S?

I had been talking to Gary Karns at ADL about getting the Linuxbios running on our system. We are using the MSMP5 (PII/266) - Gary tells me they use the same board, only the processor and graphics chip are different - and I don't know how this will interact with linuxbios.

We are looking to use linuxbios on our medical monitoring system, mainly for (boot) speed issues. I am happy to help out with development tasks, provided I am comfortable with level of effort needed.

I will touch bases with Gary on this.



Phil Brooks - Software Engineer
Olympic Medical
philb at

-----Original Message-----
From: Ronald G Minnich [mailto:rminnich at]
Sent: Wednesday, October 30, 2002 12:47 PM
To: linuxbios at
Subject: smartcore PIII is up; G2 & G4 efforts started. 

This is a PIII?750 in a PC/104 form factor. Fast!

This one was a pain. Where it stands:
- it is up, but I have to set IOBASE to 0x2000. There is hardware (ACPI)
  at 0x1000 that I can't get to turn off, it seems. This problem has
  never cropped up on piix4e before, so I'm not sure what happened here
- etherboot still can't work the ethernet interface. But it can load
  from IDE, and Linux has no troubles at all, so we put a beoboot
  Phase 1 boot in CF and let etherboot load Linux, which then boots.

Other than that it works fine. I'm working on a better solution to these

On another note, we have several folks starting G2 and G4 work. Just FYI.


Linuxbios mailing list
Linuxbios at

More information about the coreboot mailing list