LinuxBios "official" requirements.

Stefan Reinauer stepan at
Tue Apr 13 08:36:01 CEST 2004

* Mathieu Deschamps <mdeschamps at> [040409 15:53]:
> I've read several documentation on LinuxBios and related 
> projects, though I didn't find out a LinuxBios requirements
> "true" paper.  I still have the 2.4.xx kernel compiling oriented slab
> that is to say : GNU Make  3.77, ECGS 1.1.2 (GCC 2.91.66),
> Binutils 2.10, util-linux 2.10.

egcs is pretty much outdated. I've been using:

> Also I had a quite old python version (1.1 or so), i got it updated
> to 2.2.3 when I've seen the python script insulted me while running
> buildtarget. 
Anything older than 2.1 won't work.

> What I try to say is that a REQUIEREMENTS file in the source tree LACKS,
> Maybe it lacks also in the site page (IMHO, the early page info should
> mention this)...

Maybe it would make sense to enhance the available LinuxBIOS on AMD64
document (freebios2/documentation/LinuxBIOS-AMD64.pdf) to contain
information about the other ports as well. LinuxBIOS v2 does a great job
unifying things.


More information about the coreboot mailing list