Opteron / Tyan motherboard fault on boot.

Eric W. Biederman ebiederman at lnxi.com
Fri Aug 20 11:49:01 CEST 2004

Dave Belfer-Shevett <dbs at stonekeep.com> writes:

> On Thu, 2004-08-19 at 19:29, Eric W. Biederman wrote:
> > mkelf-linux does not know how to bypass the BIOS calls so
> > it will not work under LinuxBIOS.
> > 
> > Please get mkelfImage 2.5 
> > 
> > ftp://ftp.lnxi.com/pub/mkelfImage.
> Thanks Eric, but I think the problem is deeper than this.
> I just tried to start Linuxbios on the machine, with no network cable,
> no drives, no nothing.  It starts up, comes to the Boot from (N)etwork
> (D)isk (F)loppy or (Q)uit.
> I hit 'Q' here.

The 'Q' option is generic in etherboot and it does not do anything sensible
under LinuxBIOS.  So you are probably triggering a triple fault again.
It does look like the code you have does not know how to reboot properly
but that is a minor issue.

> And I get LinuxBIOS- [date date] starting...
> Unknown Trwt
> So this is happening way before the image is even downloaded.

> I'm experiencing other problems with this bios image as well.  I can't
> boot of hard drive or off floppy, it justs, for [D]isk boot  "probing
> pci disk [IDE] LBA48mode, disk-1...
> Searching for image...
> <abort>
> Probing pci disk...
> [IDE]
> Probing isa disk...
> <sleep>
> Boot from (N)etwork...

Unless you have an ELF header at the start of your disk that is likely
the culprit.  

The simple path is to get etherboot working with an image created by mkelfImage.
> When I replace the BIOS chip back with the AMI original image, I'm able
> to boot from floppy without a problem.

You have a cluster node with a floppy drive?

> So, my next step is to rebuild my linuxbios image, and flash it again...
> but... it appears that cvs.sourceforge.net is down.  Does anyone have a
> recent checkout of the CVS tree I can wget or ftp?  Please IM or mail
> me...

More information about the coreboot mailing list