epia problem/Epia status update

mark.wilkinson at 2pmtech.com mark.wilkinson at 2pmtech.com
Sun Dec 5 23:03:01 CET 2004

Hi Ron, Luc,

Quoting "Ronald G. Minnich" <rminnich at lanl.gov>:

> On Sat, 4 Dec 2004, Luc Belliveau wrote:
>> Here is the output from lspci on my board
>> *00:00.0 Host bridge: VIA Technologies, Inc. VT8601 [Apollo 
>> ProMedia] (rev 05)
>> 00:01.0 PCI bridge: VIA Technologies, Inc. VT8601 [Apollo ProMedia AGP]
>> 00:11.0 ISA bridge: VIA Technologies, Inc. VT8231 [PCI-to-ISA 
>> Bridge] (rev 10)
>> 00:11.1 IDE interface: VIA Technologies, Inc.
>> VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
>> 00:11.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
>> Controller (rev 1e)
>> 00:11.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
>> Controller (rev 1e)
>> 00:11.4 Bridge: VIA Technologies, Inc. VT8235 ACPI (rev 10)
>> 00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 AC97
>> Audio Controller (rev 40)
>> 00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 
>> [Rhine-II] (rev 51)
>> 01:00.0 VGA compatible controller: Trident Microsystems 
>> CyberBlade/i1 (rev 6a)
>> *
>> What did you want me to double check about my IDE exactly?  I 
>> haven't changed
>> any of the defaults in LinuxBIOS with the exception of the
>> CONFIG_CONSOLE_SERIAL8250 and the loglevels.
> I don't know how to set IDE back into non-native PCI and I'm not sure what
> Mark has done. FILO is finding the IDE controller just fine. We need to
> start looking at settings on the 8231 to make sure the IDE is in
> non-native mode. I'm on travel and can't help until next week but I hope
> Mark can.

I've not touched the southbridge code that set's up the ide in CVS yet, so it
should be as it was before the big code cleanup. I'm working on seperating it
out in my private copy, so I'm not sure what's happening here.

It sound's like the vt8231_init routine in vt8231.c is either not running, or
that enable_native_ide is set to 1 somewhere, check the latter first.

> ron
> _______________________________________________
> Linuxbios mailing list
> Linuxbios at clustermatic.org
> http://www.clustermatic.org/mailman/listinfo/linuxbios


This message was sent using ISPMailNow.com

More information about the coreboot mailing list