Filo Error Help

David Aubin daubin at
Thu Jul 8 17:06:01 CEST 2004


  With your elf I get the following:
boot: uda1:/ram0_2.5_2.6.5_k8.2_mydisk7.elf
LinuxLabs USB bootloader
New USB device, setting address 2
Manufacturor: Kingston
Product: DataTraveler2.0
Serial: 07B1F140E000617B
Found USB block device 2
Mounted reiserfs
boot: uda1:/ram.elf
Loading Linux version 2.6.5 (root at tst288xsuse9) #11 SMP Mon May 10
14:58:17 PDT 2004...
Jumping to entry point...
DFA Just before C's xstart32
Firmware type: LinuxBIOS
old bootloader convention, maybe loadlin?
Bootdata ok (command line is root=/dev/ram0 rw console=tty0
RAMDISK driver initialized: 16 RAM disks of 16384K size 1024 blocksize
loop: loaded (max 8 devices)
usb 2-3: new full speed USB device using address 2
scsi4 : SCSI emulation for USB Mass Storage devices
  Vendor: Kingston  Model: DataTraveler2.0   Rev: 4.70
  Type:   Direct-Access                      ANSI SCSI revision: 02
SCSI device sda: 1019392 512-byte hdwr sectors (522 MB)
sda: assuming Write Enabled
sda: assuming drive cache: write through
 sda: sda1
Attached scsi removable disk sda at scsi4, channel 0, id 0, lun 0
NET: Registered protocol family 2
IP: routing cache hash table of 2048 buckets, 32Kbytes
TCP: Hash tables configured (established 65536 bind 65536)
NET: Registered protocol family 1
NET: Registered protocol family 17
RAMDISK: Compressed image found at block 0
RAMDISK: incomplete write (-28 != 1) 16777216
crc error
EXT2-fs warning: mounting unchecked fs, running e2fsck is recommended
VFS: Mounted root (ext2 filesystem).
Freeing unused kernel memory: 472k freed
Kernel panic: No init found.  Try passing init= option to kernel.

This makes me feel a little better as it appears it is something 
in my etherboot-filo configuration perhaps?

On Thu, 2004-07-08 at 17:53, YhLu wrote:
> I wonder if it is after gzip or before gzip.
> -----Original Message-----
> From: ron minnich [mailto:rminnich at] 
> Sent: Thursday, July 08, 2004 2:44 PM
> To: David Aubin
> Cc: YhLu; LinuxBIOS
> Subject: RE: Filo Error Help
> On Thu, 8 Jul 2004, David Aubin wrote:
> >      If so could it be a size issue?  My initrd is 8Meg.  
> oh! 
> did you config the kernel for that? default is 4M.
> ron

More information about the coreboot mailing list