unreliably booting off a BCM5701.

Eric W. Biederman ebiederman at lnxi.com
Tue Mar 23 18:02:01 CET 2004

Stefan Reinauer <stepan at suse.de> writes:

> * Eric W. Biederman <ebiederman at lnxi.com> [040322 19:59]:
> > Stefan Reinauer <stepan at suse.de> writes:
> > > Also, I could not get beyound this point with a Linux 2.6.5rc1 kernel.
> > > Linux 2.4.x boots through to userland... It looks like a kernel issue,
> > > but could it come from mkelfImage?
> > 
> > Possibly.  Either that or you got hit with the changes to the
> > 2.6.x config option changes.  I have booted a 2.6 kernel.  So unless
> > it is a very recent change things should still work.
> I definitely have booted 2.6 kernels up to 2.6.2 under LinuxBIOS as
> well. 

Ok that is peculiar.  2.6.5rc1 has some patches to head.S which possibly
accounts for it as soon as I have a moment I will check and see if
that is what breaks it.  From the looks the changes to head.S should
not break anything....
> > Have you tried memtest86?  I am quite curious to if your memory
> > is working solidly.  With all of your bootloaders going haywire
> > I really don't know what to think.
> No memtest yet, but filo and etherboot, and linux kernel 2.4 - When they
> get loaded, they seem to work seamlessly...

So the etherboot and filo issues were resolved?

> > This might be a glitch in 5.3.recent as well.  I have not looked
> > in detail at what is going on there.  I can't think of anything
> > that would cause a failure like that.
> 5.3.recent?

5.3.x is the development version, and there is some major development
going on there to implement pxe support so I don't know what is
going on.


More information about the coreboot mailing list