EPIA-M "Magic Potion"?

Kevin O'Connor kevin at koconnor.net
Fri Mar 26 19:57:01 CET 2004

On Fri, Mar 26, 2004 at 12:27:31PM -0600, John Laur wrote:
> You will have to forgive me; I am still pretty green with this whole
> thing. Which model/part number do you need exactly? I have included some
> information here, but if you need to know something else, please just
> let me know, and I'll be happy to provide it.
> I am using an RD1-PL Bios Savior with the original BIOS chip in the
> socket. Flash_rom recognizes neither the original BIOS nor the backup
> flash part (I don't know exactly what chip the RD1-PL uses offhand.)

The RD1-PL is working fine on my EPIA M9000:

[root at tiny bios]# ./flash_rom romimage
Calibrating timer since microsleep sucks ... takes a second
Setting up microsecond timing loop
184M loops per second
OK, calibrated, now do the deed
Enabling flash write on VT8235...tried to set 0x45 to 0x55 on VT8235 failed (WARNING ONLY)
Trying Am29F040B, 512 KB
probe_29f040b: id1 0x7f, id2 0x45
Trying At29C040A, 512 KB
probe_jedec: id1 0xbf, id2 0xb6
Trying Mx29f002, 256 KB
probe_29f002: id1 191, id2 182
Trying SST29EE020A, 256 KB
probe_jedec: id1 0xbf, id2 0xb6
Trying SST28SF040A, 512 KB
probe_28sf040: id1 0x7f, id2 0x45
Trying SST39SF020A, 256 KB
probe_39sf020: id1 0xbf, id2 0xb6
SST39SF020A found at physical address: 0xfffc0000
Part is SST39SF020A
Programming Page: 0063 at address: 0x0003f000

This is with the switch set to "RD1".

Couple of notes:

- don't run the setpci command that is in the epia-m readme.  It causes all
  sorts of errors (if you already ran it, reboot and run flash_rom

- My flash_rom was compiled back in November; it is possible flash_rom has
  regressed.  If you're still having problems I can email you my binary.

- I guess it is also possible that there are different RD1-PL models out


More information about the coreboot mailing list