EPIA-M "Magic Potion"?

Dmitry Borisov jbors at mail.ru
Sun Mar 28 21:35:01 CEST 2004

Subject: RE: EPIA-M "Magic Potion"?

> Ron, Dimitry,
> Not to get too far ahead of myself here, but it seems CVS is probably
> not completely broken. I am booting into LinuxBIOS fine, just there is
> no PCI Bus #1 and no IRQ's are assigned to anything.
> The reason VGA is not initializing is because for some reason LinuxBIOS
> is not seeing PCI Bus #1 and thus can't locate an 0x0300 VGA class PCI
> device when it goes to init the VGA BIOS; otherwise, I think it would
> probably work fine. The IRQ problem is a more serious issue...
> Since memory detection is waiting on the v2 port and we have the flash
> problem at least identified, I'm going to poke at this VGA/PCI/IRQ thing
> some more and see what I can see...
> Any ideas?
> John

Here is the patch to make EPIA-M work with splash and VGA. See attached
config for my settings...

FYI:  I did some changes in hardwaremain.c to make sure splash is called
after VGA init and early enough to see the splash.
It may brake some other builds, unlikely though...

-------------- next part --------------
A non-text attachment was scrubbed...
Name: epia-m-vga-splash.patch.gz
Type: application/octet-stream
Size: 10755 bytes
Desc: not available
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20040328/e19dccb4/attachment.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: example.config
Type: application/octet-stream
Size: 1486 bytes
Desc: not available
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20040328/e19dccb4/attachment-0001.obj>

More information about the coreboot mailing list