Epia-MII VGA not working ...

Mathieu Deschamps mdeschamps at mangrove-systems.com
Mon May 17 03:35:01 CEST 2004

well you can try to V2 but you'll see that VGA bios isn't as far
"worked" as it is in v1.
I'am not as far as you've gone, because you have this i don't:

found VGA: vid=1106, did=3122
0x55 0xaa 0x70 0xe9 0xfc 0x7f 0x8b 0x1b 0x34 0xde 0xca 0x83 0x0 0x0 0x0
0x0 bus/

in fact i'am still seeking the HOWTOs of this (even for V1) in maillist
and such, i've found some piece of info but nothing explaining what to
do like some sort of step by step experiment... that is why I was likely
to ask your way :) or your links to theses howto. 

I know almost only V2, i've been working on V1 only a few weeks, then i 
fork to V2 and still work mainly on it.
V2 is totaly refactored, romcc compiler is a central part. Probally the
harder as I felt, is to find the good combinaison of config option
corresponding to v1 ones. for example, if i'am not mistaken, v2 has no
IDT config option for VGA bios, thus making you wonder where to start
with V2 VGAbios. All that said, i found in V2 an answer to the need 
of structure/architecture V1 spotted, and the source tree is a lot
"clearer" and  "close" solutions were incorporated .. 

Also i think acpi isn't more worked on v2, i've read to deact. it
anytime i could as i done; but I'am not sure maybe some other people
won't confirm.


Le lun 17/05/2004 à 10:02, Ignacio Verona a écrit :
> Ron:
> Thanks for your answ. Reading the serial output can you say something
> about the PCMCIA problem?
> And what about tft? May be cause VGA no to work? Right now I do not have
> any CRTs here...
> Mathieu:
> Yes, I'm on v1 right now. And about the combined filo+vgabios payload this
> is what I do for creating:
>       dd if=filo.elf of=vga+filo.bin bs=1 seek=65536
> And using vga+filo.bin as my payload linuxbios still boot up to the
> kernel, but VGA does not come up.
> Maybe could I go to V2 for beeing exactly on the same point as you? I
> could give it a try this tonight.
> Also: Do you know if acpi is working on V2? I've plans to "try" (only try,
> I don't know if I've the required programming skills) to implement it on
> v1, but if it's working on v2 I could skip this step and do all the job on
> VGA.
> Thanks!
> > Hi
> >
> > It seems i am on the same point as you. This project is simply
> > fascinating, and so much time consuming :)
> >
> > I've done this famous dd with the kcore and so on, but i think to do
> > miss something.
> > I've got a classic crt screen but nothing appear either.  Also I'am
> > working with v2 . my Linuxbios is booting to the kernel so this is ok.
> >
> > What is not, is that VGABIOS on V2 LB is not fully operationnal, i want
> > to make it be. Please could you tell me how you did "append it to my
> > filo payload like the HOWTO says and modified the config file" as ?
> > It could geratly help me in trying to make a port to V2 since i've
> > understood you are in V1, don't you ?
> >
> > Though the details of your experiments could unstuck me.
> >
> >
> > Le dim 16/05/2004 à 21:47, Ignacio Verona a écrit :
> >> Hi! Linuxbios is working prety well now on my Epia mII 10k, but a few
> >> problems:
> >>
> >> 1. I can't get VGA to work. I've extracted it from a original-bios
> >> booted
> >> system with
> >>     dd if=/proc/kcore of=video.bios.bin bs=1 count=65536 skip=790528
> >> and then appended it to my filo payload like the HOWTO says I've to do,
> >> and modified the config file with all the options in EPIA howto, but
> >> nothing shows up on my monitor (tft screen, has it something to do
> >> with?)
> >>
> >> 2. If I boot up my mobo without the PCMCIA/CF module on, it boots
> >> properly
> >> but, if I put it on and try to boot, linux bios does somethings and then
> >> reboot, forever. any known bug about this?
> >>
> >> thanks!
> >>
> >> _______________________________________________
> >> Linuxbios mailing list
> >> Linuxbios at clustermatic.org
> >> http://www.clustermatic.org/mailman/listinfo/linuxbios
> >>
> >
> _______________________________________________
> Linuxbios mailing list
> Linuxbios at clustermatic.org
> http://www.clustermatic.org/mailman/listinfo/linuxbios

More information about the coreboot mailing list