VGA Problem about 440bx chipset

Chiu Gerald snow2moutain at
Sat Sep 4 01:44:01 CEST 2004

Wow! I got it!
I use another S3 video card,and succeeded in bringing up the VGA,and booted 
RedHat linux.
So wonderful linuxbios is!
Richard Smith,thanks for your help very very much!

>From: Richard Smith <rsmith at>
>To: LinuxBIOS <linuxbios at>
>Subject: Re: VGA Problem about 440bx chipset
>Date: Wed, 01 Sep 2004 10:04:52 -0500
>Chiu Gerald wrote:
>>you mean that PCI card works?
>Yes some PCI cards work.  I've made several Assiliant 65550 and 
>based PCI cards work and some S3 based cards work.  There are 
>reports of
>some ATI cards working but I am still having problems getting my ATI 
>based card to work.
>>Now I changed to a PCI video card,and bochs had run the vga 
>>bios,but still nothing happened!
>>I have no idea what should I do next.
>Are you setting up the shadowing correctly?  You have to setup the
>shadowing in loader.s or bochs and the video bios never make it into
>ram.  The stock ADLO setup won't work on the 440bx.
>I've attached my loader.s which sets up the shadowing correctly.
>Also the DEBUG_SERIAL option in rombios.c is very useful.  You can
>enable it and all the bochs bios messages will be redirected out the
>serial port.  This way you can see if bochs rombios is even getting
>called.  You have to turn it back off to get text on the VGA screen.
>But your cards VSYNC should happen regardless. (assuming the vbios 
>I leave in a few hours and won't be back till Tuesday the 2nd so you 
>on your own for a few days.  I'll try to check email during that 
>but I'm not promising anything.
>Search the mailing list for things like "ADLO", "vgabios", etc there 
>several threads on getting this up.

与联机的朋友进行交流,请使用 MSN Messenger:  

More information about the coreboot mailing list