[LinuxBIOS] Compiling errors for flashrom

Stefan Reinauer stepan at openbios.org
Thu Dec 15 21:30:28 CET 2005

* Richard Smith <smithbone at gmail.com> [051215 17:25]:
> On 12/15/05, Christian Sühs <chris at suehsi.de> wrote:
> > BTW: GCC 2.96 compiles the flashrom tool without any warnings and
> > errors. At time it seems the tool works correct. It recognized the right
> > chipset and the right EEProm Chip.

weird. gcc 3.3.5 from SUSE 9.3 and gcc 4.0.2 from SUSE 10 work fine. You
should definitely avoid using gcc 2.96 when possible.

> What SVN rev are you using?  I thought Stefan reciently fixed up all
> the compile and alignment issues to work with newer compilers.

I did indeed. Just tested r2145 with gcc version 4.0.2 20050901
(prerelease) (SUSE Linux)

I'll look into those warnings asap though I am a bit confused. Usually
gcc 4.x is a lot more verbose with warnings than 3.3.x


More information about the coreboot mailing list