[LinuxBIOS] Compiling errors for flashrom

Christian Sühs chris at suehsi.de
Thu Dec 15 22:22:23 CET 2005

> weird. gcc 3.3.5 from SUSE 9.3 and gcc 4.0.2 from SUSE 10 work fine. You
> should definitely avoid using gcc 2.96 when possible.

Unfortanetly, with gcc 2.96 I'm not able to compile the LB image itself :D

Furthermore, I work on a selfmade minimal distro, but I will try to 
compile a working gcc version to compile both, flashtool and the image 
without any warnings

Currently I'm wondering about the differences in gcc. For flashtool I 
get warnings for comparisons between signed and unsigned only, without 
the -Werror Flag and the gcc 3.3 version. Why isn't gcc backwards 

Now I have the tool compiled with gcc 2.96 and it works, but compiling 
the image with gcc 3.3 results in the same warnings and a few warnings 
more. It could be, that the image won't work :(

However, I will test the results the next days and stay tuned :D

regards chris


I think i can mail to in german, is it so ??

More information about the coreboot mailing list