[LinuxBIOS] LNXI Merge: lnxi-patch-11/16

Stefan Reinauer stepan at openbios.org
Tue Sep 6 12:08:50 CEST 2005


* jason schildt <jschildt at lnxi.com> [050903 00:03]:
> +/* We can reduce the size of code generated by romcc by
> + * changing all of the fixed size types that live in registers
> + * into simple unsigned variables. (ie s/uint8_t/unsigned/g)
> + */

Why is this? I would consider specifying an 8bit type to be more
space-safing than using some generic untyped integer value. If not this
should be fixed in romcc..

>  	/* AMD K8 Unsupported 1Ghz? */
>  	if (id == (PCI_VENDOR_ID_AMD | (0x1100 << 16))) {
> -	        if (is_cpu_pre_e0())  // CK804 support 1G?

> +		device_t dev_2 = PCI_DEV(0,0x18,2);
> +              	if(pci_read_config32(dev_2,0x9c) < 0x20f00) {

The function call looks a lot more readable here. How much is the gain
of manual inlining here?

Stefan




More information about the coreboot mailing list