[LinuxBIOS] New Target for LinuxBios MB1030 / 3036

Christian Sühs chris at suehsi.de
Sat Apr 22 12:42:55 CEST 2006

> Running the bios under the emu is tricky.  It may be bailling out
> early although normally it prints a messge.  Search the archives for
> info.  You will probally have to add debug printf's to see whats going
> on.

Ok, yesterday evening I have found the testbios faq on the linuxbios page.

I have tried it twice.

1. extracted vgabios from fuctory bios.
2. bios get with dd command from /dev/mem

The result of first try I have described before, it happens nothing.

The second try seems to be more successfully :D
The screen goes to black :D after a second. No more. The connected TFT 
holds the signal. There is a short flickering after 30 seconds I think.
(The reason for no output on the console is the FB Mode. I have 
sometimes problems, if I start a normal program, than there is no output 
too and I need to press <return> for a while to get a prompt)
The system is still running but the only way to get a new try is 
<ctrl><alt><del> to shutdown and reboot the system.

Than I have made tests with my host system, to see what happens.
I get a vga.bin with dd and try it. (PCI Nvidia Graphic Card)

I get a lot of numbers on the console for about 5 seconds, than the 
screen switched to black and the monitor lost the signal and goes to 
stand by. The system is still running but only
<strg><alt><del> helps.

Mmmh, both systems runs in FB Mode, could that be the reason for no more 
output? Should I try the bios on a real console?

What does USER Space mean in the wiki?


> --
> Richard A. Smith

More information about the coreboot mailing list