[LinuxBIOS] MB1030 / 3036 VGA comes up :D

Christian Sühs chris at suehsi.de
Fri Apr 28 11:51:43 CEST 2006

Goodrich,Steven schrieb:
> Hmm... Let me back up a step.  I'm apparently answering a question
> you're not asking.  Your problem is that you want to disable the
> internal video (and PCI header) and use external, right?  Is that it?

Yes, but
Not really external, the "onboard" Cyberpro 5000 graphic chipset looks 
like a integrated pci card with own memory. I guess external is the 
right word for that :D

Under factory bios, the device 00:12.4 is not shown with lspci.
We know, that it is possible to disable the special graphic instructions 
for the Geode CPU, but I think 00:12.4 is the integrated graphic stuff 
at the southbridge cs5530.
So, is it automaticaly disabled, when the Geode Graphic stuff is 
disabled or is there a magic bit for the cs5530 itself?

However, it would be fine to totally disable device 00:12.4

Our current main problem is the slow coming up "external" vga device.
It takes around 90 seconds to initialize this device under LB with the 

>>Our preferred settings for this platform were:
>>BC_XMAP_1 = 0x1300C060

That could help, currently is it set to 0x60

>>BC_XMAP_2 = 0x09999999
>>BC_XMAP_3 = 0x99****99 (* = don't care)
> Or perhpaps just confuse things more.  9's in XMAP2 is PCI accessable,
> No Cache, No Write, Read.

What about CPU revisions, could it be that this registers have changed 
in the time? I guess, I use an older datassheet.


More information about the coreboot mailing list