[LinuxBIOS] MB1030 / 3036 VGA comes up :D

Stefan Reinauer stepan at coresystems.de
Fri Apr 28 19:26:05 CEST 2006

* Richard Smith <smithbone at gmail.com> [060428 17:49]:
> This is actually something that I've wanted to look at but not had the
> time.  The emulator in LB is from the same parent as X.org but its not
> the same at all.  Our base revision is quite old.
The base revision should be 0.8 iirc, so its the latest one released
from scitechsoft. (BTW, does anyone know why scitech put it to

There are some patches in our tree that are potentially missing in the
X.org tree and a lot more patches are missing the other way round.

> Yes I know we fixed a lot bugs in our tree but the fact remains that I
> can take the X.org setup in a multi-card, multi-head enviroment and it
> will post the 2nd card in almost every card I've tried.  Our user
> space emu has nowhere near that level of success.
Yes, the bios emulation in our setup is absolutely minimal, most stuff
is commented out. So we really only emulate the PCI interrupt 1a. No
surprise lots of cards don't work that work in X..

> I think an upstream sync or at least a diff with the current emu in
> X.org would be a good idea.  I'ts been on my list of stuff to do.  But
> time, money.. yada yada.

Yes, it has on mine, and on Egbert's (Egbert Eich from the FreeDesktop
project, CCed) as well.. I already set up a development repository for
that a couple of years ago, but we never got to work on that any

Another thing is still we should go vm86 mode instead of x86 emulation.
X.org does the same and they're successful with it.


coresystems GmbH • Brahmsstr. 16 • D-79104 Freiburg i. Br.
      Tel.: +49 761 7668825 • Fax: +49 761 7664613
Email: info at coresystems.dehttp://www.coresystems.de/

More information about the coreboot mailing list