[LinuxBIOS] LinuxBIOS on ASUS P2B-L

Don Waugaman dpw at email.cs.arizona.edu
Fri Aug 4 07:23:02 CEST 2006

On Thu, 2006-08-03 at 10:13 -0500, Richard Smith wrote:
> > hardware smbus problems.  Which is good.
> > I've still got that p2b so I'll test and see if I get the same results as you.
> >
> I pulled out my old p2b board and manged to find all the stuff to make
> it boot.  Then ran the current V2 p2b target build.
> Indeed it dumps the SPD out just fine.  So yah!  Thats good news.  My
> V1 stuff must have had some other issue that kept the RAM from getting
> detected properly.

Good to hear you're getting the same results!

Since you straightened me on what to expect, I went ahead and changed
the southbridge/i440bx to i82371eb, and recompiled all the 440bx targets
I could find (successfully, except that the eaglelion/5bcm tried to look
for a payload under /home/hamish, which for some reason didn't exist on
my system :-).  I've attached a patch for this - could you review and
commit for me?  I think it may require some svn magic to copy/remove the
old 440bx directory and files - I'm not sure how well just applying the
diffs here will work (I'm an svn newbie).

I'll tackle rebasing the RAM init on the e7501 next.



-------------- next part --------------
A non-text attachment was scrubbed...
Name: i82371eb.patch
Type: text/x-patch
Size: 13862 bytes
Desc: not available
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20060803/b7d609bb/attachment.patch>

More information about the coreboot mailing list