[LinuxBIOS] EPIA M COM2 problem + possible solution?

Ragnar ragnar at hansarinne.fi
Wed Feb 22 17:15:30 CET 2006


I just started to play with linuxbios and a EPIA-M 6000,
and everything worked fine first trial, except for the COM2 port.

The COM2 was recognised by the kernel but it was not
responding to changes on the input pins.

After finding the vt1211 datasheet with google,
I notice that there is a register in the vt1211 that
controls UART2 pin selection. Reading this register after
booting with linuxbios, I got 0xff. So according to
the datasheet COM2 pins are not used by the UART2 but by
somthing else.

So by changing this register to 0x00, and COM2 works fine. But
according to the datasheet the default value for this
register is 0x00 which I interpret as reset value? So can
there be some code somewhere that set this register to 0xff,
for some other board using the vt1211 that have these pins
connected to something else than COM2?

Five of these pins can be used for monitoring an intel P6,
and two can be used as SMBus but I guess the SMBus is
controlled by the southbridge, and the last one is
Infrared Tranciever Module on/off control. So my best
guess is that for the EPIA M board, this pin select
register should set to 0x00, but since I'm a beginner
and don't have the bigger picture, this is just a guess.
But it works fine for me.

I have been using version 2100, but the vt1211 code
doesn't seems to have changed since then.

Here is a patch of this trivial change to v1211.c, probably not
so good, but it works for me on the EPIA M 6000.

> 		        pnp_write_config(dev, index + 0, (iobase >> 2) & 0xff);
> 		        break;
> 		        pnp_write_config(dev, 0x27, 0x00); /* Set pin selection to 
serial port */


More information about the coreboot mailing list