[LinuxBIOS] cant detect bios with flash software {Scanned}

Stefan Reinauer stepan at coresystems.de
Fri Jun 30 22:16:47 CEST 2006

* Stefan Reinauer <stepan at coresystems.de> [060630 21:49]:
> > Im not sure what u mean by verifing that the image starts 25 a6??? are
> > you talking about an image file taken from the BIOS using VIAs flash
> > utility?
> I thought that might be the vendor and device id. In fact it is 8c and
> 00, as it is a 256kb part

Ok, can you please check out revision 2336. I checked in some untested
support for your flash part.

Can you try the following:

Please be careful which chip you use at a time. If you mess the order up
you will most likely render your system unusable ...

1. make a copy of your bios:

   switch to the EFST, then do:

    ./flashrom -r legacybios.bin

2. write the copy to your bios savior

   switch to the bios savior (Winbond W49F002U)

    ./flashrom -w legacybios.bin

3. Verify the copy in the bios savior

    ./flashrom -v legacybios.bin

4. Overwrite the EMST flash to see if the new flashbios version works

   switch to the EMST again!

    dd if=/dev/zero of=nullbios.bin bs=256k count=1
    ./flashbios -w nullbios.bin
    ./flashbios -v nullbios.bin

   (it should say "verified" here!!!!)

   then you can write the original bios back to the EMST so you have
   two valid copies for playing later.

   ./flashbios -w legacybios.bin
   ./flashbios -v legacybios.bin   

Please post the results here..

coresystems GmbH • Brahmsstr. 16 • D-79104 Freiburg i. Br.
      Tel.: +49 761 7668825 • Fax: +49 761 7664613
Email: info at coresystems.dehttp://www.coresystems.de/

More information about the coreboot mailing list