[LinuxBIOS] Lippert Cool Roadrunner 2 (GX1)

Per Dalgas Jakobsen pdj at knaldgas.dk
Fri Mar 3 17:42:54 CET 2006

Hi all,

At last... Finally I have had time to look at LinuxBIOS...
I have been playing around with Etherboot and Filo for booting a
development target, making good progress.

Up to now I have managed to add Etherboot to the original BIOS and have
it working fine.

But now I want to LinuxBIOS my system ;-)

I have a Lippert Cool Roadrunner II with 64MB memory and a 128MB
CompactFlash for disk, and I have tried to use LinuxBIOS v1 with its
support for this board, but no success.

The serial port is very quite, and unfortunately I have no POST card. I
have verified the serial connection: Linux on target "$ echo Hello
>/dev/ttyS0" gives a nice "Hello" on the receiving end (no handshakes),
so something seems odd with the LinuxBIOS image...

Host is i686-Linux using gcc-4.0.3

--- config ------------
target /home/pdj/tuxway/builds/roadrunner2
mainboard lippert/roadrunner2

# Enable Serial Console for debugging
option TTYS0_BAUD=57600

option DEBUG=1

option RAMTEST=1
option USE_ELF_BOOT=1
option ROM_SIZE=262144
option STD_FLASH=1

payload ~/tuxway/etherboot-5.0.6/src/bin32/eepro100.elf

option PAYLOAD_SIZE=196608

I've hexdump'd the resulting romimage, and it looks fine as far as I can
tell: (jmp far 0xf000:0x0004 at address 0x0003fff0, and payload image
starting at 0x00000000).

I've used the flashrom from LinuxBIOSv2-2191 for burning:
"# flashrom -w romimage"

Anyone able to give me a clue of what I've missed?

Anyone had success with LinuxBIOSv2 on a Roadrunner2 ?


My ultimate goal is fast boot to either a remote image (through
Etherboot) or a local linux on CompactFlash (filo and ext2).

My plan was to use LinuxBIOS with a combined filo and etherboot image as
Like this:
0x000000 FILO
0x010000 ETHERBOOT
0x030000 LINUXBIOS
I have already modified filo so an external switch can select the

More information about the coreboot mailing list