[LinuxBIOS] QEMU 0.9.0 fails to compile

roger roger at eskimo.com
Wed Apr 11 05:25:43 CEST 2007

Seems you're using gcc-3.2.

I'm using gcc-4.1.1 and Qemu (finally) compiled fine with gcc-4 along
with KQemu. (Although, I'm seeing some system freezes but have yet to
verify it was because KQemu was loaded.)

Anyways, try upgrading to a more recent gcc version first.

Just a note, I've yet to try building LinuxBios along with the latest
Qemu release.  I'm still getting some flash parts together for working
with my 440BX.

On Tue, 2007-04-10 at 15:53 -0700, Andon Tschauschev wrote:
> Hello,
> I have just tried to compile QEMU 0.9.0 (with qemu-isa-bios-ram.patch
> and  qemu-piix-ram-size.patch applied) on my machine, but it failed.
> Output from configure:
> qemu-0.9.0 $ ./configure  --target-list=i386-softmmu        
> WARNING: "gcc" looks like gcc 4.x
> Looking for gcc 3.x
> Found "gcc32"
Key fingerprint = 8977 A252 2623 F567 70CD 1261 640F C963 1005 1D61

Tue Apr 10 20:25:26 PDT 2007

More information about the coreboot mailing list