[LinuxBIOS] How to enable VGA on Tyan S3992?

Feng, Libo Libo.Feng at amd.com
Fri Apr 27 09:05:45 CEST 2007

I play some trick. Rom_address(src/devices/pci_rom.c) is manually set to 0xfff80000 if class is detected as 3 and subclass is detected as 0 (VGA device). The boot log shows on a monitor, too. The attached is the boot log. But it is against the purpose of PCI, hardware independence, I still need a complete solution. Thank you for your support these days, Mr Lu. 

PCI: 00:0c.0 init
rom address for PCI: 00:0c.0 = fc220000
BTDC: device class = 0
BTDC: device class = 3
BTDC: set rom_address manually
copying VGA ROM Image from 0xfff80000 to 0xc0000, 0x9000 bytes
entering emulator
un-inited int vector
halt_sys: file /home/fengl/LinuxBIOSv2-2584/src/devices/emulator/x86emu/ops.c, line 4387
Best Regards

??? Feng Libo @ AMD  Ext: 20906
Mobile Phone: 13683249071
Office Phone: 0086-010-62801406

-----Original Message-----
From: yhlu [mailto:yinghailu at gmail.com] 
Sent: Friday, April 27, 2007 2:43 PM
To: Feng, Libo
Cc: tsylla at gmail.com; linuxbios at linuxbios.org
Subject: Re: How to enable VGA on Tyan S3992?

it looks familiar about mmio resource allocation is not right.

It seems i fixed it some time ago, but it is still in my tree.

Let me compare public tree with my own tree this weekend, or I will send your my partial tree to you.


-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: Tricky.txt
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20070427/938a6f80/attachment.txt>

More information about the coreboot mailing list