[LinuxBIOS] [PATCH] Re: m57sli-s4 and i2c

Ward Vandewege ward at gnu.org
Sat Apr 28 22:43:59 CEST 2007

Hi ST,

On Sat, Apr 28, 2007 at 01:43:56AM +0200, ST wrote:
> Mh, i just tried it and doesn't work for me :-(. Probably i am to tired and 
> did a stupid mistake. But well i still can't load the it87 module. But my 
> tree has the changes in superio.c. Hints are welcome :-). Probably im am 
> missing a kernel driver or so?

I suspect you don't have the other patch that was submitted under r2620 - the
changes to Config.lb for the m57sli-s4 ?

> Ward i have also the problem that i don't see any classic PCI cards on my 
> machine (with linuxbios, works with stock bios), can you confirm this? I see 
> all the nvidia stuff and the video card though.

I'll look into that next week, when I'm back at the office.

> I have written a small c program which reads out the values of the ec 
> controller. It works for me under stock bios but gives "ff" on all reads 
> under linuxbios :-(. Ward it would be nice if you could try it on your 
> machine... and yes i was a little bit off with my statement can be take right 
> of the datasheet. The program needs to be run as root or gives an access 
> error.

Sure, I had figured that much; my perl script still didn't work. I'll give
your program a go and get back to you next week.

> Attached is also the output of the program on my machine under i386 and amd64. 
> Keep in mind that some of the registers are fan and temperature input so they 
> differ.

Very helpful, thanks!


Ward Vandewege <ward at fsf.org>
Free Software Foundation - Senior System Administrator

More information about the coreboot mailing list