[LinuxBIOS] Setting up ethernet - help

Joseph Smith joe at smittys.pointclark.net
Tue Aug 14 18:06:25 CEST 2007

OK I am having a problem setting up my ethernet controller in  
src/mainboard Config.lb.

Quoting from the i82830 Datasheet:
Logically, the ICH3-M appears as two PCI devices within a single  
physical component also residing on PCI bus #0. One of the ICH4  
devices residing on PCI Bus #0 is a PCI-to-PCI bridge. Logically, the  
primary side of the bridge resides on PCI bus #0 while the secondary  
side is the standard PCI expansion bus (PCI0). Also within the ICH3-M  
is another PCI Device, the LAN Controller, which resides on the  
standard PCI expansion bus (PCI0) down from the PCI-to-PCI bridge.

lspci -n
00:1e.0 0604: 8086:244e (rev 82)
01:08.0 0200: 8086:103a (rev 82)

-[0000:00]-+-1e.0-[0000:01]----08.0  Intel Corporation 82801DB PRO/100  
VE (CNR) Ethernet Controller

00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 82)  
(prog-if 00 [Normal decode])
	Flags: bus master, fast devsel, latency 0
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
	I/O behind bridge: 0000d000-0000dfff
	Memory behind bridge: ff700000-ff7fffff

01:08.0 Ethernet controller: Intel Corporation 82801DB PRO/100 VE  
(CNR) Ethernet Controller (rev 82)
	Flags: bus master, medium devsel, latency 64, IRQ 11
	Memory at ff7ff000 (32-bit, non-prefetchable) [size=4K]
	I/O ports at dc00 [size=64]
	Capabilities: [dc] Power Management version 2

How the heck do I set this up in Config.lb? HELP??

Thanks - Joe

More information about the coreboot mailing list