[LinuxBIOS] LZMA compression of kernel image and p7zip (Carl-Daniel Hailfinger / Stefan Reinauer)

liran tal liransgarage at gmail.com
Thu Aug 30 17:06:23 CEST 2007

Hey everyone,

I have stumbled upon posts by Carl-Daniel and Stefan while trying to get
information why when I compile a kernel image with 7zip (LZMA) the kernel
image doesn't load up.

The specific post is -

I figured that maybe you could help diagnosing this problem as it seems that
I have
found the problem but I am not too sure actually.

I have been given an SDK based on Linux 2.6.10 for an embedded mips 4Kec (TI
Avalanche series) cpu
to build an image from. When I build the image using GZIP (standard) the
kernel boots fine but when I
choose 7ZIP support for better compression, the 'make ram_zimage' procedure
is working successfully
but when the image attempts to run off the device (via nfs) it writes:

        Launching kernel decompressor.
        Starting LZMA Uncompression Algorithm.
        Compressed file is LZMA format.
        Kernel decompressor was successful ... launching kernel.

and nothing happens after that.
I've been attempting to figure out what is causing the kernel not to load
and after reading
the post by Carl-Daniel and Stefan about 7zip using different headers than
"normal" LZMA sdk
I thought that this could be the problem.

I understand that this is not the best forum to ask, being a linuxbios
but I would appreciate your comments and any help on this issue as I am
trying to understand what is going on.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20070830/11b259b2/attachment.html>

More information about the coreboot mailing list