[LinuxBIOS] different versions of the GA-M57SLI-S4 (PLCC vs SPI)

Carl-Daniel Hailfinger c-d.hailfinger.devel.2006 at gmx.net
Sat Dec 8 13:27:41 CET 2007

On 07.12.2007 20:28, Richard Smith wrote:
> Carl-Daniel Hailfinger wrote:
>>> fancontrol and cool'n'quite and the powerdown is missing without acpi.
>>> i think there is just no acpi code in the lb part for the m57sli4
>>>>> flashrom isn't working when lb is booted.
>>>> Only on the newer boards i suppose?
>>> only on the spi version of the board. (rev 2.0)
>> Can someone with a logic probe or oscilloscope debug that? Once I know
>> what's wrong with the signals, I can fix the code.
> I'll be happy to.
> So to verify:
> I need to boot LB (what svn rev?) on M557SLI-S4 rev 2.0 and then figure 
> out what signal is not working correctly when you try to reflash with 
> flashrom.

Current svn revision, please. The rest exactly like you described.

IIRC Florentin wanted to trace this as well. Maybe you can coordinate? I
have no idea whether I have internet access tomorrow.
The patch below may help to force writes to the chip. Maybe you need to
comment out the other busy wait loops as well and replace them with
usleep(1000) or something like that.

Index: spi.c
--- util/flashrom/spi.c	(Revision 2998)
+++ util/flashrom/spi.c	(Arbeitskopie)
@@ -163,9 +163,9 @@
 	uint8_t busy, writeenc;
 	int i;
-	do {
+	/*do {
 		busy = inb(port) & 0x80;
-	} while (busy);
+	} while (busy); */
 	if (readcnt > 3) {
 		printf("%s called with unsupported readcnt %i.\n",
 			__FUNCTION__, readcnt);


More information about the coreboot mailing list