[LinuxBIOS] Buildrom setup broken for GA-M57SLI?

Ward Vandewege ward at gnu.org
Sat Dec 8 22:40:28 CET 2007

On Sat, Dec 08, 2007 at 01:26:30PM -0500, Richard Smith wrote:
> Doesn't seem to work for me.
> The -fno-stack-protector checking isn't working. 

Yep, known bug that needs fixing.

>After hacking the 
> necessary makefiles to have -fno-stack-protector I get:

Great, can you supply a patch?

> gcc -m32 -nostdlib -nostartfiles -static -o linuxbios -T ldscript.ld crt0.o
> /usr/bin/ld: section .id [00000000ffffef64 -> 00000000ffffef7f] overlaps 
> section .rom [00000000ffff5e28 -> 00000000fffff00f]
> /usr/bin/ld: linuxbios: section .id lma 0xffffef64 overlaps previous 
> sections
> /usr/bin/ld: linuxbios: section .reset lma 0xffffeff0 overlaps previous 
> sections
> collect2: ld returned 1 exit status
> make[2]: *** [linuxbios] Error 1
> Which IIRC means that my linuxbios image is too big. 

Yep. Did you do a make distclean && make ? I really have to do that after
every change / failed build.

> The build tutorial 
> for this board seems to suggest that this is supposed to work.  Is this 
> a regression or is my Ubuntu gutsy toolchain to blame?

I build images just fine on a 32-bit Gnewsense (i.e. Dapper) box. Your rom
chip is 1MB or bigger right (assuming you're doing LAB) - otherwise 512K is

I've only tested file, etherboot and LAB payloads recently on this board.
Kernel might work just fine too. Memtest probably needs a modified Config.lb.


Ward Vandewege <ward at fsf.org>
Free Software Foundation - Senior System Administrator

More information about the coreboot mailing list