[LinuxBIOS] SST49LF004A/B chip is not detected in MSI MS-7250 VER:2.2 (K9N Ultra) Motherboard

Corey Osgood corey.osgood at gmail.com
Sat Dec 29 10:11:22 CET 2007

Kiran Patil wrote:
> On Dec 28, 2007 7:30 PM, Carl-Daniel Hailfinger
> <c-d.hailfinger.devel.2006 at gmx.net
> <mailto:c-d.hailfinger.devel.2006 at gmx.net>> wrote:
>     On 28.12.2007 14:29, Kiran Patil wrote:
>     >           MSI MS-7250 VER:2.2 (K9N Ultra) motherboard is not
>     detecting
>     > SST49LF004A/B chip.
>     >
>     > I am attaching the following files,
>     >
>     > flashrom.log -- Which contains flashrom --verbose output
>     >
>     It seems we are missing a board enable routine for the K9N Ultra.
>   But the motherboard detects Pm49FL004 chip.
>   Please find the attached log file.
>   Thanks,
>   Kiran.

Are you absolutely certain that the chip is an SST49LF004? You aren't
using a BIOS Savior with a switch in the wrong position? I know this
sounds a little odd, but here's the deal: the flash chip vendor and
model that flashrom is reporting aren't anywhere near what they should
be for that chip. So, either you have a different chip, or else the
board is somehow masking the chip ID, and reporting a false one. It
could be that the board is somehow disabling access to its own flash
chip, and instead copying the BIOS contents to ram (although the more I
think about it, the more far-fetched and maybe even impossible that
sounds). Do you have a floppy drive that you can use uniflash to try to
flash, or at least identify, this chip?


More information about the coreboot mailing list