[LinuxBIOS] UART questions on porting LinuxBIOS to GX2 + CS5535, help please!!

lihao lihao at mprc.pku.edu.cn
Sun Feb 4 06:21:27 CET 2007

Hi, all!
    I am doing porting jobs on GX2(GX-533 at 1.1w) + cs5535. I am using OLPC/rev_a directory as my starting point. I know that OLPC use GX2(GX-500 at 1.0w, right??) + cs5536. From POST card i see the code runs far behind the code of auto.c(src/mainboard/olpc/rev_a/auto.c), and there should be some information printed from uart1, actually there is none. 
    As for cs5536, i see cs5536_setup_onchipuart() called before uart_init(), and i find the MSRs handled in cs5536_setup_onchipuart do exist in cs5535. So i added a function named cs5535_setup_onchipuart in cs5535_early_setup.c, and call that functions in auto.c. The same result, nothing printed from uart1.
    I googled related information, i found someone said we must first loaded VSA before we can use internal uart of cs5535. I have a little bit understanding on VSA. From my point of view, i see VSA is an auto tools for OS to access standard x86 compatible registers and ios from not fully x86 compatible system like cs5535. And i think cs5535_setup_onchipuart handles accessing msr in cs5535 manually as what VSA should do and we do not need to firstly load VSA at auto.c. If I were right, why nothing appears from uart??
    Any advice would be well appreciated.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20070204/deb38483/attachment.html>

More information about the coreboot mailing list