[LinuxBIOS] epia, rom_cc and locking code

Ben Hewson ben at hewson-venieri.com
Tue Jan 16 19:33:02 CET 2007

ron minnich wrote:
> On 1/14/07, Ben Hewson <ben at hewson-venieri.com> wrote:
>> there are some posts on the mailing list I made, but basically my older
>> version of linuxbios using filo boots, but a later version after the
>> rom_cc patch doesn't boot any more.
>> exactly the same hardware and filo image (v 0.5 ).
> can you get us a source-level diff?
> ron
as I have been putting in some extra debug to see if I could locate the
problem, I updated to the latest version.
just to check the problem is still there I have tried to build, and it
does build ok but it won't load the filo payload.

I am guessing this is to do with the new CONFIG_ROM_PAYLOAD_START setting.
When I boot  I get the following

Welcome to elfboot, the open sourced starter.
January 2002, Eric Biederman.
Version 1.3

rom_stream: 0xfffc0000 - 0xfffcffff
NO header at 0
NO header at 16
NO header at 32
NO header at 48
NO header at 8096
header_offset is -1
Cannot Load ELF Image

I assume this is to do with CONFIG_ROM_PAYLOAD_START. Do you have any
advice at what I need to set it to ?

anyway assuming the problem still exists I have attached the output from
diff.  As I havent really used diff very much, let me know if you need
something more/different.


-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: diff
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20070116/c2cf748e/attachment.ksh>

More information about the coreboot mailing list