[LinuxBIOS] LinuxBIOSv1 won't build?

Corey Osgood corey_osgood at verizon.net
Tue Jan 23 07:08:50 CET 2007

I've got my laptop back, and I'm trying to compile linuxbios for the rcn 
dc1100s, since it has the same setup as the tyan s2507, but I keep 
getting compile errors. With gcc 3.3.6:

dualp3 dc1100s # make
Makefile:501: warning: overriding commands for target `keyboard.o'
Makefile:414: warning: ignoring old commands for target `keyboard.o'
gcc -x assembler-with-cpp -DASSEMBLY -E ... crt0.S > crt0.s
gcc ... -o crt0.o crt0.s
crt0.S: Assembler messages:
crt0.S:153: Warning: indirect jmp without `*'
gcc ... -o linuxbiosmain.o /home/amp/LinuxBIOSv1/src/lib/linuxbiosmain.c
/home/amp/LinuxBIOSv1/src/lib/linuxbiosmain.c: In function `linuxbiosmain':
/home/amp/LinuxBIOSv1/src/lib/linuxbiosmain.c:66: error: `root' 
undeclared (first use in this function)
/home/amp/LinuxBIOSv1/src/lib/linuxbiosmain.c:66: error: (Each 
undeclared identifier is reported only once
/home/amp/LinuxBIOSv1/src/lib/linuxbiosmain.c:66: error: for each 
function it appears in.)
/home/amp/LinuxBIOSv1/src/lib/linuxbiosmain.c:66: error: syntax error 
before '/' token

I remember that at some point, there was some discussion about v1 not 
building, but I can't seem to find it. Anyone have a patch to fix this? 
I hate to go diving into v1 if someone already has a fix. Or heck, if 
someone's already got a rom built with FILO (I assume you can use filo 
with v1), that would do even better :-D


More information about the coreboot mailing list