[LinuxBIOS] Filo boot from CD-Rom syntax

roger roger at eskimo.com
Mon Jan 29 08:04:01 CET 2007

On Mon, 2007-01-29 at 14:14 +0800, bxshi wrote:
> >ie. CD-ROM device is to be specified as "hdc1" and not "hdc"!
> I installed one IDE HDD and one IDE CD-ROM and use filo in etherboot .
> Filo recognize the IDE hdd as hda, and the Cd-rom as hdb. 
> in Config file I specify:
> AUTOBOOT_FILE = "hdb:/isolinux/vmlinuz initrd=/isolinux/initrd.img
> expert nofb acpi=off devfs=nomount #ramdisk_size=65536
> console=ttyS0,115200"
> it installs OS well . it seems we don't need to specify CDROM to
> hdb1 .hdb works well. 

I'm working for the "boot:" prompt of file-0.5 & it does require the
specific designation of "hdc1" (or other device file with a numeral 1 as
the suffix) to be probed properly from the "boot:" prompt.  As well as,
the filo-0.5/Config file).

However,  you are right, If you'll notice in my Filo output, Filo is
automagically probing both my cdrom drives with only one CD-ROM drive
being designated. :-)

I'm planning on playing with some of my Atmel and DOC2000(MD2802) flash
devices in a couple of days after I solder an extension wires w/
wirewraps from my motherboard 32 Pin DIP/TSOP socket.  So, I'll
follow-up on this once I'm able to flash w/o issues of yanking PCI cards
out of my motherboards to provide space for a ziff socket.   

>From your notes, I'm speculating too Filo is probably working ok and it
might just be having issues under the Qemu emulator.

Key fingerprint = 8977 A252 2623 F567 70CD 1261 640F C963 1005 1D61

Sun Jan 28 22:56:38 PST 2007

More information about the coreboot mailing list