[LinuxBIOS] mcp55 flashrom problem

Ward Vandewege ward at gnu.org
Thu Mar 1 06:15:33 CET 2007

On Wed, Feb 28, 2007 at 09:11:21PM -0800, Ed Swierk wrote:
> On 2/28/07, Ward Vandewege <ward at gnu.org> wrote:
> > It looks like flashrom is not disabling shadow properly. This is probably
> > related to my patch of earlier today that added a new pci id for this
> > particular board's MCP55 (0x0360). Flashrom only knew about 0x0364 and 0x0367
> > for the MCP55.
> >
> > I also saw a patch from Ed Swierk a couple of weeks ago, which added a whole
> > bunch of PCI ids for the MCP55 (among which the 0x0360), but was never
> > applied to the tree.
> >
> > Can someone who knows the MCP55 have a look at the enable_flash_mcp55
> > function in flash_enable.c and figure out what's wrong?
> >
> > Yinghai, can you tell us which board(s) you've tested the enable_flash_mcp55
> > function on?
> That's odd. flashrom works fine on my DFI LANParty board, with the
> patch I submitted that adds PCI ID 0x360. Maybe shadowing is enabled
> only on certain vendors' BIOSes.

So, you've verified that the image that flashrom reads matches what you can
download from the manufacturers website (extracted)?

Flashrom doesn't crash or anything here, and it might just *write* fine (not
tested yet), but reading gives the wrong data. We know, because we got the ID
for the chip back, that at least a couple of writes to the chip succeeded.


Ward Vandewege <ward at fsf.org>
Free Software Foundation - Senior System Administrator

More information about the coreboot mailing list