[LinuxBIOS] uart_init hangs?

Uwe Hermann uwe at hermann-uwe.de
Mon Mar 26 14:39:53 CEST 2007

On Mon, Mar 26, 2007 at 02:10:20AM -0400, Corey Osgood wrote:
> Alright, I know I ask too many questions, but what would cause uart_init
> to hang? I'm trying to get serial output on ite it8705f, and my POST
> card tells me that it's hanging during uart_init. I've made a bunch of
> changes to it8705f_early_serial.c, mainly to set up serial port 1
> manually, but nothing seems to help. Also, there's one small error in
> the last line of that file, according to the datasheet:
>     it8705f_sio_write(0x00, IT8705F_CONFIG_REG_CC, 0x02); //need to
> change 0x02 to 0x01

This line is correct, I think. The datasheet says

  Set bit 1 of the Configure Control Register (Index: 02h) to "1" to exit
  the MB PnP mode.

IT8705F_CONFIG_REG_CC is 0x02, and the 0x02 in the line above is correct
because it sets bit 1 (not bit 0).

I _think_ I got serial output with that Super I/O at some point, but I
can't remember exactly, so maybe there's still something todo...

http://www.hermann-uwe.de  | http://www.holsham-traders.de
http://www.crazy-hacks.org | http://www.unmaintained-free-software.org
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20070326/e86423d7/attachment.sig>

More information about the coreboot mailing list