[LinuxBIOS] r2670 - in trunk/LinuxBIOSv2/src/mainboard: asus/p2b bitworks/ims densitron/dpx114 via/epia via/epia-m
uwe at hermann-uwe.de
Thu May 17 13:26:41 CEST 2007
On Tue, May 15, 2007 at 11:01:48PM -0400, Corey Osgood wrote:
> > spd_read_byte() is the correct name, so it should stay IMO. Is there a
> > reason why all/most boards define this as a wrapper for smbus_read_byte()?
> > Could this be something else than smbus_read_byte() for some board?
> > If no, maybe a #define is easier? Or move the wrapper to a central
> > location?
> okay, I guess this is the real question: is there ever any case where or
> reason why spd_read_byte doesn't just return smbus_read_byte?
Yes, I think so -- the Geode stuff and/or the 'fake SPD' method will
need a different spd_read_byte() implementation. Please let's stick with it.
http://www.hermann-uwe.de | http://www.holsham-traders.de
http://www.crazy-hacks.org | http://www.unmaintained-free-software.org
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 189 bytes
Desc: Digital signature
More information about the coreboot