[LinuxBIOS] #87: flashrom issues on m57sli-s4

Carl-Daniel Hailfinger c-d.hailfinger.devel.2006 at gmx.net
Mon Nov 12 12:30:33 CET 2007

On 08.11.2007 15:05, LinuxBIOS wrote:
> #87: flashrom issues on m57sli-s4
> -------------------------+--------------------------------------------------
>     Reporter:  ward      |         Owner:  hailfinger       
>         Type:  defect    |        Status:  new              
>     Priority:  major     |     Milestone:                   
>    Component:  flashrom  |       Version:  v2               
>   Resolution:            |      Keywords:                   
> Dependencies:            |   Patchstatus:  there is no patch
> -------------------------+--------------------------------------------------
> Changes (by hailfinger):
>   * owner:  somebody => hailfinger
> Comment:
>  I need superiotool output for a board with parallel flash running under
>  LB. NOW.
>  AFAICS the flash configuration is totally botched on LB with floating
>  GPIOs, wrong timing etc.
>  I have a patch pending which will solve the flashing problem on all M57SLI
>  boards, but I refuse to send it to the list before I have superiotool
>  output to verify.

Since trac seems to be down, this message goes to the list:

Flashing parallel flash is fixed in r2955.

To be able to autodetect presence of serial flash, I'd like full
superiotool output for
* board with parallel flash
* board with serial flash
both running LinuxBIOS r2955 or later.
I hope to find a bit which differs in superio configuration that can be
used to select the right code path for enabling SPI flash (decode and
flash functionality).


More information about the coreboot mailing list