[LinuxBIOS] [patch] Fix M57SLI interrupt routing

Harald Gutmann harald.gutmann at gmx.net
Mon Nov 12 23:10:22 CET 2007

Am Dienstag, 6. November 2007 01:25:28 schrieb Torsten Duwe:
> On Tuesday 06 November 2007 00:40, Torsten Duwe wrote:
> > On Monday 05 November 2007, Carl-Daniel Hailfinger wrote:
> > > Do you still need irqpoll?
> >
> > Rebuilding and rebooting right after this mail ... :-)
> ...now posting from it.
> No more irqpoll, glxgears at full performance, both PCI slots' INT A
> working. PCIe 16x INT A working. No more lost interrupts.
today i tried rev 2955 from LB with your patch for getting the PCI's working.
what i can tell is:
the pci slot to the edge is listed, and the device appears in /proc/interrups,
also firewire shows up in lspci. in the other pci-slot there is no card in my 

one problem remains:
the nvidia grapic card won't start up with X11 and the propritary nvidia 
driver. i get the following error message from X:
"(EE) NVIDIA(0): The NVIDIA kernel module does not appear to be receiving
(EE) NVIDIA(0):     interrupts generated by the NVIDIA graphics device
(EE) NVIDIA(0):     PCI:7:0:0.  Please see Chapter 8: Common Problems in the
(EE) NVIDIA(0):     README for additional information.
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!"

i've the rev. 2.0 from this mainboard. the superiotool output from lb in 
rev.2955 is attaced in the thread to bug #87 and also the output from the 
propritary bios is to find there.

> Save for the untested FireWire, interrupts are basically working now for
> me.
> 	Torsten

More information about the coreboot mailing list