[LinuxBIOS] #87: flashrom issues on m57sli-s4

Carl-Daniel Hailfinger c-d.hailfinger.devel.2006 at gmx.net
Tue Nov 13 16:53:54 CET 2007


On 13.11.2007 16:36, Harald Gutmann wrote:
> Am Dienstag, 13. November 2007 16:08:01 schrieb Carl-Daniel Hailfinger:
>   
>> On 13.11.2007 15:27, Harald Gutmann wrote:
>>     
>>> Am Dienstag, 13. November 2007 02:27:21 schrieb Carl-Daniel Hailfinger:
>>>       
>>>> We have to change
>>>> * NOLDN idx 0x24 (Flash)
>>>> * LDN 0x07 idx 0x64+0x65 (Flash), 0xc9 (Simple I/O)
>>>> The rest of the differences is either "don't care" at the moment or
>>>> changing is actively harmful.
>>>> If we ever decide to support automatic fan control and stuff like that,
>>>> we have to revisit LDN 0x04.
>>>> If we ever decide to NOT support EPP/ECP parallel port modes, we have to
>>>> revisit LDN 0x03.
>>>>
>>>>
>>>> Try this patch:
>>>>         
>>> done, but flashrom fails.
>>> here is a diff from the lb-superiotool output from rev2955 to the
>>>       
> "rev2955" from the linuxbios image, without your patch.
>
>   
>>> superiotool output from rev2958 with your patch.
>>>       
> "rev2958 with your patch" <- from linuxbios image with the last patch from 
> this thread.
>   

Strange. None of the changes in my patch show up in your superiotool
output. That either means these registers are special or some part of
the patch was ineffective or it was not applied.

The changes in superiotool output have no relation at all to the patch.
LDN 0x7 idx 0xc9 should have value 0x40, but your diff claims it is
still 0x0. Since everything else is normal, the only possible conclusion
is that you either booted an image without my patch (not necessarily
your fault) or something magic resets all values to those from a
revision without my patch.

Did you remove the build directory before rebuilding? Did you power off
the machine before booting with the patch? Can you run superiotool
before running flashrom?


Regards,
Carl-Daniel




More information about the coreboot mailing list