[LinuxBIOS] [PATCH] Small improvements for BCOM WinNET100

Uwe Hermann uwe at hermann-uwe.de
Thu Oct 11 03:30:38 CEST 2007

On Wed, Oct 10, 2007 at 08:36:07PM +0200, Juergen Beisert wrote:
> Did you change website's content? I added some test results to it, can you 
> change the colours of the fields?

Yep, done now. There was some Slashdot-related downtime, so I couldn't
do it earlier.


> Why: "Tested with irqpoll kernel parameter. Tested: USB thumb drive."? 
> My patch contains a valid IRQ routine table! All right, to use it, the kernel 
> needs a patch...

Yes, I was just too lazy to recompile kernels yesterday, so I used
irqpoll for now (which is slower, but works too). Will test your patches later.

I have not yet read all of your PDF and all code, but there seem to be
lots of useful patches in there... I hope we can merge all/most of them
soon (in LinuxBIOS as well as in Linux). Please send patches for
the stuff which is ready to be committed...

Currently I'm using FILO + a 2.5" hard drive on my IGEL-316 which works
fine with the attached patch. With "irqpoll" both USB and ethernet also
work fine with a stock 2.6.22 kernel.

Audio and VGA doesn't work, I guess I'll need your patches/drivers.
The "nsc" Xorg driver requires VSA, correct? The LinuxBIOS VGA part
works fine, the logo is displayed!

Some questions about the status table at

 - For "COM2" you wrote: "Simple UART mode only (due to TTL level)".
   What exactly does that mean? There's no COM2 connector an the
   back, and I don't see any headers to attch one on the board, either.
   Is COM2 usable somehow?

 - I didn't test the parallel port with anything useful yet, but simply
   doing 'modprobe ppdev' works without errors, the module loads fine.

 - Any ideas about the smartcard reader? Not that I need it, but it
   would be useful to know the status. Do we know something about how
   it works (datasheets?) or is there even some Linux driver for it?
   Does it need special init in LinuxBIOS?

Oh, and btw, someone seems to have had a lot of fun (this is from
the original BIOS image):

$ strings bcom_winnet100_bios.img | grep -C 5 "All Your"
This configuration may exhibit bug #293. Contact your Application Engineer.
                         All Your Base Are Belong To Us.
                           Move Zig! , For Great Justice.
                                   What You Say?!!
                           Somebody Set Us Up The Bomb!
                     You Have No Chance To Survive Make Your Time.

http://www.hermann-uwe.de  | http://www.holsham-traders.de
http://www.crazy-hacks.org | http://www.unmaintained-free-software.org
-------------- next part --------------
A non-text attachment was scrubbed...
Name: v2_bcom_winnet100_fixes.patch
Type: text/x-diff
Size: 4357 bytes
Desc: not available
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20071011/3ab19bd3/attachment.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20071011/3ab19bd3/attachment.sig>

More information about the coreboot mailing list