[LinuxBIOS] Missing IRQ table entries; irq_tables.c problem?

Jonathan Sturges jonathansturges at yahoo.com
Tue Sep 18 04:39:20 CEST 2007

>On Sun, Sep 16, 2007 at 06:56:55PM -0700, Jonathan Sturges wrote:
>> Thanks Uwe,
>> That was it!  I added 'option IRQ_SLOT_COUNT=3' to the Config.lb in the target directory of my board, and >>that did the trick.  I now get IRQs assigned to all 3 devices I intended to.  Very nice!
>Nice, indeed! Does everything else work on your board?
>Either way, please post a patch so we can add it to the repository.

Tested: serial port (well, 1 of them, for console of course), IDE, Ethernet, USB OHCI, and Mini-PCI.  Untested are VGA and audio (it's a Geode and I haven't dug into using VSA or the alternatives), as well as PS/2 kbd. and mouse.

It is extremely stable under Fedora Core 5 and kernel 2.6.20.  This winterm is a great embedded system, if you don't need the VGA or audio.  It's working well enough to commit to the repository, I just need to read up on how to properly create a new mainboard and target first.

One thing I'd like to investigate as well is initializing the IRQ router in LB.  I've seen some discussion about this in the past, and I've come to the conclusion that for Geode GX1/CS5530 systems, it should be initialized in LB rather than Linux.  It also seems like some LB ports do this, and others do not.  Is there an official position on this from the core maintainers?


Pinpoint customers who are looking for what you sell. 

More information about the coreboot mailing list