[LinuxBIOS] Ethernet problem with GeodeLX (db800) with running lxbios

Peter Stuge peter at stuge.se
Thu Sep 20 13:18:02 CEST 2007

On Wed, Sep 05, 2007 at 09:57:20AM +0200, Steffen D. wrote:
> > Do you get interrupts?
> I show you whats happening :)
> r8169: eth0: link up
> r8169: eth0: link up
> r8169: eth0: link up
> ... and again... and again
> this message comes two times a second.

I think the best way to find the problem is to add huge amounts of
trace printk to the r8169 driver. (Even though the problem indeed is
in LB.)

Do you have access to the full data sheet (registers and all) for
the NIC?

> The other side of iperf:
> [  3]  1.0- 2.0 sec  16.0 KBytes    131 Kbits/sec
> [  3]  2.0- 3.0 sec  0.00 Bytes  0.00 bits/sec
> [  3]  0.0- 7.4 sec  64.0 KBytes  71.3 Kbits/sec

Only traffic during the first 2 seconds. Hm.

> # cat /proc/interrupts
>  11:        354    XT-PIC-XT        ohci_hcd:usb1, ehci_hcd:usb2, eth0
> I dont know how to read this interrups or what they say to me,
> sorry. Any idea?

The first column is the interrupt number, 11.
The second is the interrupt count since Linux start. 354 interrupts.
Third is the mode that the interrupt controller is running in.
AMD, is XT-PIC-XT correct for the LX platform?
Fourth is the list of drivers/interfaces that are sharing this

Since it's shared between eth0 and USB we can't see reliably if you
are getting interrupts from the NIC.

Start with disabling USB until this is solved. Then look at the
interrupt count before and after trying to communicate with the
system. When running iperf the number should increase fairly

Again, it's important to disable USB (unloading the driver is enough)
so that you can be sure of the interrupt source.

On Thu, Sep 20, 2007 at 05:09:05AM +0200, Steffen D. wrote:
> we really have a big problem with that ethernet bug - we currently
> developing a new product based on a geode-lx cpu and not comming
> forward.
> Because we are not a big firm we dont have the man power/knowlege
> to fix it - can anybody help us with this problem?

Maybe I can help.

> We can send $you the hardware if you need it.

Depends.. I don't have access to a logic analyzer and only a 40MHz
analog scope so it may be better to send $me to you if you have a
good lab. (I'm in Malmö, Sweden.)

> Also remote connection to the system is no problem.

Over serial then, I hope. :)

> hopefully somebody got time.

Not a lot - but maybe enough?


More information about the coreboot mailing list