[coreboot] patch: mcp55 smbus
rminnich at gmail.com
Tue Aug 12 00:38:54 CEST 2008
On Mon, Aug 11, 2008 at 2:12 PM, Carl-Daniel Hailfinger
>> +static int lsmbus_recv_byte(struct device *dev)
> Please change the function name to mcp55_smbus_recv_byte.
are you sure? it's a static. Does it really matter? I'ts been this way in v2 for
years. What's the motivation for making *static* names unique? I think file sco
pe is good enough for this.
>> +#ifdef HAVE_ACPI_TABLES
>> +unsigned pm_base;
> No global variables until you ack and commit my global var patch.
> By the way, not only is the current state of global vars non-functional,
> it also has the nice side-effect of corrupting the CAR area randomly.
This is stage 2; not an issue here.
> separate set_subsystem function, please.
see my commenton IRC w.r.t. this. This is not V2 :-)
More information about the coreboot