[coreboot] patch: mcp55 smbus
c-d.hailfinger.devel.2006 at gmx.net
Tue Aug 12 03:56:12 CEST 2008
On 12.08.2008 00:38, ron minnich wrote:
> On Mon, Aug 11, 2008 at 2:12 PM, Carl-Daniel Hailfinger
>>> +static int lsmbus_recv_byte(struct device *dev)
>> Please change the function name to mcp55_smbus_recv_byte
> are you sure? it's a static. Does it really matter? I'ts been this way
> in v2 for years. What's the motivation for making *static* names
> unique? I think file scope is good enough for this.
I overlooked that one. However, if it ever becomes non-static, we should
revisit the issue.
>>> +#ifdef HAVE_ACPI_TABLES
>>> +unsigned pm_base;
>> No global variables until you ack and commit my global var patch.
>> By the way, not only is the current state of global vars non-functional,
>> it also has the nice side-effect of corrupting the CAR area randomly.
> This is stage 2; not an issue here.
>> separate set_subsystem function, please.
> see my commenton IRC w.r.t. this. This is not V2 :-)
See my patch to convert this to the v3 way.
More information about the coreboot