[coreboot] [PATCH] change ipchksum parameter types

ron minnich rminnich at gmail.com
Sat Aug 30 05:36:52 CEST 2008

On Fri, Aug 29, 2008 at 4:16 PM, Peter Stuge <peter at stuge.se> wrote:

> The case is already done internally and I think that's fine. Anyways,
> since it is casted, void * works for me and my ack is still good. :)

there are a few key reasons it was defined for IP the way it was,
which make interesting reading, but the Big Picture is that the area
checksummed should be an even number of bytes long.


More information about the coreboot mailing list